CVE-2026-23745
CVE-2026-23745 · node-tar Vulnerable to Arbitrary File Overwrite and Symlink Poisoning via Insufficient Path Sanitization
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
node-tar is a Tar for Node.js. The node-tar library (<= 7.5.2) fails to sanitize the linkpath of Link (hardlink) and SymbolicLink entries when preservePaths is false (the default secure behavior). This allows malicious archives to bypass the extraction root restriction, leading to Arbitrary File Overwrite via hardlinks and Symlink Poisoning via absolute symlink targets. This vulnerability is fixed in 7.5.3.
CVSS 8.2 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
node-tar
- Softwareversionen
- < 7.5.3: Betroffen
Keine Korrektur veröffentlicht
node-tar Debian:12
- Softwareversionen
- 6.1.13+~cs7.0.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.1.13+~cs7.0.5-1+deb12u1
Auf 6.1.13+~cs7.0.5-1+deb12u1 aktualisieren
node-tar Debian:13
- Softwareversionen
- 6.2.1+~cs7.0.8-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.2.1+~cs7.0.8-1+deb13u1
Auf 6.2.1+~cs7.0.8-1+deb13u1 aktualisieren
node-tar Debian:14
- Softwareversionen
- 6.2.1+ds1+~cs6.1.13-1
- 6.2.1+ds1+~cs6.1.13-2
- 6.2.1+ds1+~cs6.1.13-3
- 6.2.1+ds1+~cs6.1.13-4
- 6.2.1+ds1+~cs6.1.13-5
- 6.2.1+~cs7.0.8-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.2.1+ds1+~cs6.1.13-6
Auf 6.2.1+ds1+~cs6.1.13-6 aktualisieren
tar npm
- Betroffene Versionsbereiche
- SEMVER: < 7.5.3
Auf 7.5.3 aktualisieren
node-tar Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 0.1.18-1
- 0.1.18-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-tar Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.0.3-2
- 1.0.3-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-tar Ubuntu:18.04:LTS
- Softwareversionen
- 2.2.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-tar Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 4.4.10+ds1-2
- 4.4.10+ds1-2ubuntu1
- 4.4.10+ds1-2ubuntu1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-tar Ubuntu:22.04:LTS
- Softwareversionen
- 6.1.7+~cs11.3.10-1
- 6.1.11+~cs11.3.10-1
- 6.1.11+ds1+~cs6.0.6-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-tar Ubuntu:24.04:LTS
- Softwareversionen
- 6.1.13+~cs7.0.5-1
- 6.1.13+~cs7.0.5-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-tar Ubuntu:25.10
- Softwareversionen
- 6.2.1+~cs7.0.8-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-tar Ubuntu:26.04:LTS
- Softwareversionen
- 6.2.1+~cs7.0.8-1
- 6.2.1+ds1+~cs6.1.13-6
- 6.2.1+ds1+~cs6.1.13-7
- 6.2.1+ds1+~cs6.1.13-10
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/isaacs/node-tar/security/advisories/GHSA-8qq5-rm4j-mr97
- https://github.com/isaacs/node-tar/commit/340eb285b6d986e91969a1170d7fe9b0face405e
- https://access.redhat.com/security/cve/CVE-2026-23745
- https://bugzilla.redhat.com/show_bug.cgi?id=2430538
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-23745.json
- https://access.redhat.com/errata/RHSA-2026:18480
- https://access.redhat.com/errata/RHSA-2026:18868
- https://access.redhat.com/errata/RHSA-2026:2900
- https://access.redhat.com/errata/RHSA-2026:41928
- https://access.redhat.com/errata/RHSA-2026:3782
- https://access.redhat.com/errata/RHSA-2026:19712
- https://access.redhat.com/errata/RHSA-2026:6192
- https://access.redhat.com/errata/RHSA-2026:2926
- https://access.redhat.com/errata/RHSA-2026:2144
- https://nvd.nist.gov/vuln/detail/CVE-2026-23745