p PatchFirst

CVE-2026-26065

CVE-2026-26065 · calibre: Path Traversal can Lead to Arbitrary File Write and Potential Code Execution

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

calibre is a cross-platform e-book manager for viewing, converting, editing, and cataloging e-books. Versions 9.2.1 and below are vulnerable to Path Traversal through PDB readers (both 132-byte and 202-byte header variants) that allow arbitrary file writes with arbitrary extension and arbitrary content anywhere the user has write permissions. Files are written in 'wb' mode, silently overwriting existing files. This can lead to potential code execution and Denial of Service through file corruption. This issue has been fixed in version 9.3.0.

CVSS 9.3 · Kritisch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • calibre

    Softwareversionen
    • < 9.3.0: Betroffen

    Keine Korrektur veröffentlicht

  • calibre Debian:12

    Softwareversionen
    • 6.13.0+repack-2
    • 6.13.0+repack-2+deb12u1
    • 6.13.0+repack-2+deb12u2
    • 6.13.0+repack-2+deb12u3
    • 6.13.0+repack-2+deb12u4
    • 6.13.0+repack-2+deb12u5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.13.0+repack-2+deb12u6

    Auf 6.13.0+repack-2+deb12u6 aktualisieren

  • calibre Debian:13

    Softwareversionen
    • 8.5.0+ds-1
    • 8.5.0+ds-1+deb13u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.5.0+ds-1+deb13u2

    Auf 8.5.0+ds-1+deb13u2 aktualisieren

  • calibre Debian:14

    Softwareversionen
    • 8.10.0+ds-1
    • 8.10.0+ds-2
    • 8.10.0+ds-3
    • 8.11.0+ds+~0.10.5-1
    • 8.11.1+ds+~0.10.5-1
    • 8.11.1+ds+~0.10.5-2
    • 8.11.1+ds+~0.10.5-3
    • 8.12.0+ds+~0.10.5-1
    • 8.13.0+ds+~0.10.5-1
    • 8.13.0+ds+~0.10.5-2
    • 8.13.0+ds+~0.10.5-3
    • 8.14.0+ds+~0.10.5-1
    • 8.14.0+ds+~0.10.5-1~bpo13+1
    • 8.15.0+ds+~0.10.5-1
    • 8.15.0+ds+~0.10.5-1~bpo13+1
    • 8.15.0+ds+~0.10.5-2
    • 8.16.0+ds+~0.10.5-1
    • 8.16.0+ds+~0.10.5-2
    • 8.16.1+ds+~0.10.5-1
    • 8.16.2+ds+~0.10.5-1
    • 8.16.2+ds+~0.10.5-2
    • 8.16.2+ds+~0.10.5-3
    • 8.16.2+ds+~0.10.5-3~bpo13+1
    • 8.5.0+ds-1
    • 8.6.0+ds-1
    • 8.7.0+ds-1
    • 8.8.0+ds-1
    • 8.8.0+ds-2
    • 8.8.0+ds-2+gcc15
    • 8.8.0+ds-3
    • 8.9.0+ds-1
    • 8.9.0+ds-2
    • 8.9.0+ds-3
    • 8.9.0+ds-4
    • 9.0.0+ds+~0.10.5-1
    • 9.1.0+ds+~0.10.5-1
    • 9.2.0+ds+~0.10.5-1
    • 9.2.1+ds+~0.10.5-1
    • 9.2.1+ds+~0.10.5-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.3.0+ds+~0.10.5-1

    Auf 9.3.0+ds+~0.10.5-1 aktualisieren

  • calibre Ubuntu:16.04:LTS

    Softwareversionen
    • 2.33.0+dfsg-1build1
    • 2.38.0+dfsg-1
    • 2.45.0+dfsg-1
    • 2.45.0+dfsg-1build1
    • 2.48.0+dfsg-1
    • 2.48.0+dfsg-1build1
    • 2.54.0+dfsg-1
    • 2.55.0+dfsg-1
    • 2.55.0+dfsg-1ubuntu0.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • calibre Ubuntu:18.04:LTS

    Softwareversionen
    • 3.7.0+dfsg-2
    • 3.7.0+dfsg-2build1
    • 3.12.0+dfsg-1
    • 3.13.0+dfsg-1
    • 3.14.0+dfsg-1
    • 3.15.0.1+dfsg-1
    • 3.16.0+dfsg-1
    • 3.16.0+dfsg-1build1
    • 3.17.0+dfsg-1
    • 3.17.0+dfsg-2
    • 3.18.0+dfsg-1build1
    • 3.19.0+dfsg-1
    • 3.20.0+dfsg-1
    • 3.21.0+dfsg-1
    • 3.21.0+dfsg-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • calibre Ubuntu:20.04:LTS

    Softwareversionen
    • 3.46.0+dfsg-1
    • 4.2.0+dfsg-2
    • 4.3.0+dfsg-1
    • 4.3.0+dfsg-2
    • 4.4.0+dfsg-1
    • 4.5.0+dfsg-1
    • 4.5.0+dfsg-2
    • 4.5.0+dfsg-3
    • 4.6.0+dfsg-1
    • 4.7.0+dfsg-1
    • 4.99.3+dfsg-2
    • 4.99.4+dfsg-1
    • 4.99.4+dfsg-1build1
    • 4.99.4+dfsg+really4.10.0+py3-2
    • 4.99.4+dfsg+really4.11.2-1
    • 4.99.4+dfsg+really4.11.2-1build1
    • 4.99.4+dfsg+really4.12.0-1
    • 4.99.4+dfsg+really4.12.0-1build1
    • 4.99.4+dfsg+really4.12.0-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • calibre Ubuntu:22.04:LTS

    Softwareversionen
    • 5.25.0+dfsg-2
    • 5.33.2+dfsg-1
    • 5.34.0+dfsg-1
    • 5.35.0+dfsg-1ubuntu2
    • 5.37.0+dfsg-1
    • 5.37.0+dfsg-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • calibre Ubuntu:24.04:LTS

    Softwareversionen
    • 6.24.0+ds-1
    • 6.29.0+ds-1
    • 7.0.0+ds-1
    • 7.1.0+ds-1
    • 7.1.0+ds-2
    • 7.2.0+ds-1
    • 7.2.0+ds-1build1
    • 7.3.0+ds-1
    • 7.4.0+ds-1
    • 7.5.1+ds-1
    • 7.5.1+ds-2
    • 7.5.1+ds-3
    • 7.6.0+ds-1
    • 7.6.0+ds-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • calibre Ubuntu:25.10

    Softwareversionen
    • 7.26.0+ds-4build1
    • 8.3.0+ds-1
    • 8.4.0+ds-1
    • 8.5.0+ds-1
    • 8.6.0+ds-1
    • 8.7.0+ds-1
    • 8.8.0+ds-2
    • 8.8.0+ds-3
    • 8.8.0+ds-3build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • calibre Ubuntu:26.10

    Softwareversionen
    • 9.2.1+ds+~0.10.5-2build1
    • 9.9.0+ds+~0.10.6-1
    • 9.11.0+ds+~0.10.6-1
    • 9.11.0+ds+~0.10.6-2
    • 9.13.0+ds+~0.10.6-1
    • 9.14.0+ds+~0.10.6-2build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • calibre Ubuntu:26.04:LTS

    Softwareversionen
    • 8.8.0+ds-3build1
    • 8.13.0+ds+~0.10.5-3
    • 8.14.0+ds+~0.10.5-1
    • 8.15.0+ds+~0.10.5-1
    • 8.16.0+ds+~0.10.5-2
    • 8.16.2+ds+~0.10.5-1
    • 8.16.2+ds+~0.10.5-2
    • 8.16.2+ds+~0.10.5-3
    • 9.2.1+ds+~0.10.5-2build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →