CVE-2026-27197
CVE-2026-27197 · Sentry: Improper Authentication on SAML SSO process allows user identity linking
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Sentry is a developer-first error tracking and performance monitoring tool. Versions 21.12.0 through 26.1.0 have a critical vulnerability in its SAML SSO implementation which allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. Self-hosted users are only at risk if the following criteria is met: ore than one organizations are configured (SENTRY_SINGLE_ORGANIZATION = True), or malicious user has existing access and permissions to modify SSO settings for another organization in a multo-organization instance. This issue has been fixed in version 26.2.0. To workaround this issue, implement user account-based two-factor authentication to prevent an attacker from being able to complete authentication with a victim's user account. Organization administrators cannot do this on a user's behalf, this requires individual users to ensure 2FA has been enabled for their account.
CVSS 9.1 · Kritisch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
sentry
- Softwareversionen
- >= 21.12.0, < 26.2.0: Betroffen
Keine Korrektur veröffentlicht
sentry PyPI
- Softwareversionen
- 21.12.0
- 22.1.0
- 22.10.0
- 22.11.0
- 22.12.0
- 22.2.0
- 22.3.0
- 22.4.0
- 22.5.0
- 22.6.0
- 22.7.0
- 22.8.0
- 22.9.0
- 23.1.0
- 23.1.1
- 23.2.0
- 23.3.0
- 23.3.1
- 23.4.0
- 23.5.0
- 23.5.1
- 23.5.2
- 23.6.0
- 23.6.1
- 23.6.2
- 23.7.0
- 23.7.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 21.12.0
Keine Korrektur veröffentlicht
sentry PyPI
- Softwareversionen
- 21.12.0
- 22.1.0
- 22.10.0
- 22.11.0
- 22.12.0
- 22.2.0
- 22.3.0
- 22.4.0
- 22.5.0
- 22.6.0
- 22.7.0
- 22.8.0
- 22.9.0
- 23.1.0
- 23.1.1
- 23.2.0
- 23.3.0
- 23.3.1
- 23.4.0
- 23.5.0
- 23.5.1
- 23.5.2
- 23.6.0
- 23.6.1
- 23.6.2
- 23.7.0
- 23.7.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 21.12.0, < 26.2.0
Auf 26.2.0 aktualisieren