CVE-2026-28384
CVE-2026-28384 · Authenticated RCE via unsanitized compression_algorithm
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
An improper sanitization of the compression_algorithm parameter in Canonical LXD allows an authenticated, unprivileged user to execute commands as the LXD daemon on the LXD server via API calls to the image and backup endpoints. This issue affected LXD from 4.12 through 6.6 and was fixed in the snap versions 5.0.6-e49d9f4 (channel 5.0/stable), 5.21.4-1374f39 (channel 5.21/stable), and 6.7-1f11451 (channel 6.0 stable). The channel 4.0/stable is not affected as it contains version 4.0.10.
CVSS 9.4 · Kritisch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
lxd
- Softwareversionen
- ≥ 6.0, < 6.7: Betroffen (semver)
- ≥ 5.21.0, < 5.21.4: Betroffen (semver)
- ≥ 5.0.0, < 5.0.6: Betroffen (semver)
- 4.12: Betroffen
Auf 5.0.6 aktualisieren; Auf 5.21.4 aktualisieren; Auf 6.7 aktualisieren
incus Debian:13
- Softwareversionen
- 6.0.4-2
- 6.0.4-2+deb13u1
- 6.0.4-2+deb13u1~bpo12+1
- 6.0.4-2+deb13u2
- 6.0.4-2+deb13u2~bpo12+1
- 6.0.4-2+deb13u3
- 6.0.4-2+deb13u3~bpo12+1
- 6.0.4-2+deb13u4
- 6.0.4-2+deb13u4~bpo12+1
- 6.0.4-2+deb13u5~bpo12+1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.4-2+deb13u5
Auf 6.0.4-2+deb13u5 aktualisieren
incus Debian:14
- Softwareversionen
- 6.0.4-2
- 6.0.4-3
- 6.0.5-1
- 6.0.5-2
- 6.0.5-3
- 6.0.5-4
- 6.0.5-5
- 6.0.5-6
- 6.0.5-7
- 6.0.5-8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.6-1
Auf 6.0.6-1 aktualisieren
lxd Debian:12
- Softwareversionen
- 5.0.2+git20231211.1364ae4-1
- 5.0.2+git20231211.1364ae4-2
- 5.0.2+git20231211.1364ae4-3
- 5.0.2+git20231211.1364ae4-4
- 5.0.2+git20231211.1364ae4-5
- 5.0.2+git20231211.1364ae4-6
- 5.0.2+git20231211.1364ae4-7
- 5.0.2+git20231211.1364ae4-8
- 5.0.2+git20231211.1364ae4-9
- 5.0.2-5
- 5.0.2-5+deb12u1
- 5.0.2-5+deb12u2
- 5.0.2-5+deb12u3
- 5.0.2-5+deb12u4
- 5.0.2-5+deb12u5
- 5.0.2-5+deb12u6
- 5.0.2-6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
lxd Debian:13
- Softwareversionen
- 5.0.2+git20231211.1364ae4-9
- 5.0.2+git20231211.1364ae4-9+deb13u1
- 5.0.2+git20231211.1364ae4-9+deb13u2
- 5.0.2+git20231211.1364ae4-9+deb13u3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.0.2+git20231211.1364ae4-9+deb13u4
Auf 5.0.2+git20231211.1364ae4-9+deb13u4 aktualisieren
Originalquellen
- https://github.com/canonical/lxd/security/advisories/GHSA-4rmf-rcp8-2r9g
- https://github.com/canonical/lxd/commit/043696a13171ace7dd4c2b32d34ce039ab629052
- https://github.com/canonical/lxd/commit/7046979645c2ce1b63b2f9e60ddf6cbc4c4b78f9
- https://github.com/canonical/lxd/commit/b7b411caf5c4971bfe2386c72128f44d7e2aaf4f
- https://discourse.ubuntu.com/t/lxd-authenticated-remote-code-execution-fixes-available/78365
- https://nvd.nist.gov/vuln/detail/CVE-2026-28384