CVE-2026-28493
CVE-2026-28493 · ImageMagick has a Integer Overflow leading to out of bounds write in SIXEL decoder
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16, an integer overflow vulnerability exists in the SIXEL decoer. The vulnerability allows an attacker to perform an out of bounds via a specially crafted image. This vulnerability is fixed in 7.1.2-16.
CVSS 6.5 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
imagemagick
- Softwareversionen
- < 7.1.2-16: Betroffen
Keine Korrektur veröffentlicht
imagemagick Debian:13
- Softwareversionen
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1+deb13u1
- 8:7.1.1.43+dfsg1-1+deb13u2
- 8:7.1.1.43+dfsg1-1+deb13u3
- 8:7.1.1.43+dfsg1-1+deb13u4
- 8:7.1.1.43+dfsg1-1+deb13u5
- 8:7.1.1.43+dfsg1-1+deb13u6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:7.1.1.43+dfsg1-1+deb13u7
Auf 8:7.1.1.43+dfsg1-1+deb13u7 aktualisieren
imagemagick Debian:14
- Softwareversionen
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.46+dfsg1-1
- 8:7.1.1.47+dfsg1-1
- 8:7.1.1.47+dfsg1-2
- 8:7.1.2.1+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.15+dfsg1-2
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.7+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:7.1.2.16+dfsg1-1
Auf 8:7.1.2.16+dfsg1-1 aktualisieren
imagemagick Ubuntu:25.10
- Softwareversionen
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1ubuntu1
- 8:7.1.1.43+dfsg1-1ubuntu2
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.3+dfsg1-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht