p PatchFirst

CVE-2026-29174

CVE-2026-29174 · Craft Commerce has a SQL Injection in Commerce Inventory Table Sorting

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 5.5.3, Craft Commerce is vulnerable to SQL Injection in the inventory levels table data endpoint. The sort[0][direction] and sort[0][sortField] parameters are concatenated directly into an addOrderBy() clause without any validation or sanitization. An authenticated attacker with access to the Commerce Inventory section can inject arbitrary SQL queries, potentially leading to a full database compromise. This vulnerability is fixed in 5.5.3.

CVSS 8.7 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • commerce

    Softwareversionen
    • >= 5.0.0 < 5.5.3: Betroffen

    Keine Korrektur veröffentlicht

  • craftcms/commerce Packagist

    Softwareversionen
    • 5.0.0
    • 5.0.1
    • 5.0.10
    • 5.0.10.1
    • 5.0.11
    • 5.0.11.1
    • 5.0.12
    • 5.0.12.1
    • 5.0.12.2
    • 5.0.13
    • 5.0.14
    • 5.0.15
    • 5.0.16
    • 5.0.16.1
    • 5.0.16.2
    • 5.0.17
    • 5.0.18
    • 5.0.19
    • 5.0.2
    • 5.0.3
    • 5.0.4
    • 5.0.5
    • 5.0.6
    • 5.0.7
    • 5.0.8
    • 5.0.9
    • 5.1.0
    • 5.1.0-beta.1
    • 5.1.0-beta.2
    • 5.1.0-beta.3
    • 5.1.0.1
    • 5.1.1
    • 5.1.2
    • 5.1.3
    • 5.1.4
    • 5.2.0
    • 5.2.1
    • 5.2.10
    • 5.2.11
    • 5.2.12
    • 5.2.12.1
    • 5.2.2
    • 5.2.2.1
    • 5.2.3
    • 5.2.4
    • 5.2.5
    • 5.2.6
    • 5.2.7
    • 5.2.8
    • 5.2.9
    • 5.2.9.1
    • 5.3.0
    • 5.3.0.1
    • 5.3.0.2
    • 5.3.1
    • 5.3.10
    • 5.3.11
    • 5.3.12
    • 5.3.13
    • 5.3.2
    • 5.3.2.1
    • 5.3.2.2
    • 5.3.3
    • 5.3.4
    • 5.3.5
    • 5.3.6
    • 5.3.7
    • 5.3.8
    • 5.3.9
    • 5.4.0
    • 5.4.1
    • 5.4.1.1
    • 5.4.10
    • 5.4.2
    • 5.4.3
    • 5.4.4
    • 5.4.5
    • 5.4.5.1
    • 5.4.6
    • 5.4.7
    • 5.4.7.1
    • 5.4.8
    • 5.4.9
    • 5.5.0
    • 5.5.0.1
    • 5.5.1
    • 5.5.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 5.0.0, < 5.5.3

    Auf 5.5.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →