p PatchFirst

CVE-2026-32112

CVE-2026-32112 · ha-mcp has XSS via Unescaped HTML in OAuth Consent Form

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

ha-mcp is a Home Assistant MCP Server. Prior to 7.0.0, the ha-mcp OAuth consent form renders user-controlled parameters via Python f-strings with no HTML escaping. An attacker who can reach the OAuth endpoint and convince the server operator to follow a crafted authorization URL could execute JavaScript in the operator's browser. This affects only users running the beta OAuth mode (ha-mcp-oauth), which is not part of the standard setup and requires explicit configuration. This vulnerability is fixed in 7.0.0.

CVSS 6.8 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • ha-mcp

    Softwareversionen
    • < 7.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • ha-mcp PyPI

    Softwareversionen
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.4.0
    • 3.4.2
    • 3.4.3
    • 3.5.0
    • 3.5.1
    • 3.6.0
    • 3.6.1
    • 3.6.2
    • 3.7.0
    • 4.0.0
    • 4.0.1
    • 4.1.0
    • 4.10.0
    • 4.11.0
    • 4.11.1
    • 4.11.2
    • 4.11.3
    • 4.11.4
    • 4.11.5
    • 4.11.6
    • 4.11.7
    • 4.11.8
    • 4.11.9
    • 4.12.0
    • 4.13.0
    • 4.14.0
    • 4.14.1
    • 4.14.2
    • 4.15.0
    • 4.15.1
    • 4.16.0
    • 4.16.1
    • 4.16.2
    • 4.17.0
    • 4.17.1
    • 4.18.0
    • 4.18.1
    • 4.18.2
    • 4.19.0
    • 4.2.0
    • 4.20.0
    • 4.21.0
    • 4.22.0
    • 4.22.1
    • 4.3.0
    • 4.4.0
    • 4.5.0
    • 4.6.0
    • 4.7.0
    • 4.7.1
    • 4.7.2
    • 4.7.3
    • 4.7.4
    • 4.7.5
    • 4.7.6
    • 4.7.7
    • 4.8.0
    • 4.8.1
    • 4.8.2
    • 4.8.3
    • 4.8.4
    • 4.8.5
    • 4.9.0
    • 5.0.0
    • 5.0.2
    • 5.0.3
    • 5.0.4
    • 5.0.5
    • 5.0.6
    • 5.1.0
    • 6.0.0
    • 6.1.0
    • 6.2.0
    • 6.3.0
    • 6.3.1
    • 6.4.0
    • 6.5.0
    • 6.6.0
    • 6.6.1
    • 6.7.0
    • 6.7.1
    • 6.7.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.0.0

    Auf 7.0.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →