p PatchFirst

CVE-2026-32621

CVE-2026-32621 · Apollo Federation has prototype pollution via incomplete key sanitization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Apollo Federation is an architecture for declaratively composing APIs into a unified graph. Prior to 2.9.6, 2.10.5, 2.11.6, 2.12.3, and 2.13.2, a vulnerability exists in query plan execution within the gateway that may allow pollution of Object.prototype in certain scenarios. A malicious client may be able to pollute Object.prototype in gateway directly by crafting operations with field aliases and/or variable names that target prototype-inheritable properties. Alternatively, if a subgraph were to be compromised by a malicious actor, they may be able to pollute Object.prototype in gateway by crafting JSON response payloads that target prototype-inheritable properties. This vulnerability is fixed in 2.9.6, 2.10.5, 2.11.6, 2.12.3, and 2.13.2.

CVSS 9.9 · Kritisch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • federation-internals

    Softwareversionen
    • >= 2.13.0-preview.0, < 2.13.2: Betroffen
    • >= 2.12.0-preview.0, < 2.12.3: Betroffen
    • >= 2.11.0-preview.0, < 2.11.6: Betroffen
    • >= 2.10.0-alpha.0, < 2.10.5: Betroffen
    • < 2.9.6: Betroffen

    Keine Korrektur veröffentlicht

  • gateway

    Softwareversionen
    • >= 2.13.0-preview.0, < 2.13.2: Betroffen
    • >= 2.12.0-preview.0, < 2.12.3: Betroffen
    • >= 2.11.0-preview.0, < 2.11.6: Betroffen
    • >= 2.10.0-alpha.0, < 2.10.5: Betroffen
    • < 2.9.6: Betroffen

    Keine Korrektur veröffentlicht

  • query-planner

    Softwareversionen
    • >= 2.13.0-preview.0, < 2.13.2: Betroffen
    • >= 2.12.0-preview.0, < 2.12.3: Betroffen
    • >= 2.11.0-preview.0, < 2.11.6: Betroffen
    • >= 2.10.0-alpha.0, < 2.10.5: Betroffen
    • < 2.9.6: Betroffen

    Keine Korrektur veröffentlicht

  • @apollo/federation-internals npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.9.6

    Auf 2.9.6 aktualisieren

  • @apollo/federation-internals npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.10.0, < 2.10.5

    Auf 2.10.5 aktualisieren

  • @apollo/federation-internals npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.11.0, < 2.11.6

    Auf 2.11.6 aktualisieren

  • @apollo/federation-internals npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.12.0, < 2.12.3

    Auf 2.12.3 aktualisieren

  • @apollo/federation-internals npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.13.0, < 2.13.2

    Auf 2.13.2 aktualisieren

  • @apollo/gateway npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.9.6

    Auf 2.9.6 aktualisieren

  • @apollo/gateway npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.10.0, < 2.10.5

    Auf 2.10.5 aktualisieren

  • @apollo/gateway npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.11.0, < 2.11.6

    Auf 2.11.6 aktualisieren

  • @apollo/gateway npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.12.0, < 2.12.3

    Auf 2.12.3 aktualisieren

  • @apollo/gateway npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.13.0, < 2.13.2

    Auf 2.13.2 aktualisieren

  • @apollo/query-planner npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.9.6

    Auf 2.9.6 aktualisieren

  • @apollo/query-planner npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.10.0, < 2.10.5

    Auf 2.10.5 aktualisieren

  • @apollo/query-planner npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.11.0, < 2.11.6

    Auf 2.11.6 aktualisieren

  • @apollo/query-planner npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.12.0, < 2.12.3

    Auf 2.12.3 aktualisieren

  • @apollo/query-planner npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.13.0, < 2.13.2

    Auf 2.13.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →