p PatchFirst

CVE-2026-32635

CVE-2026-32635 · Angular has XSS in i18n attribute bindings

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20, a Cross-Site Scripting (XSS) vulnerability has been identified in the Angular runtime and compiler. It occurs when the application uses a security-sensitive attribute (for example href on an anchor tag) together with Angular's ability to internationalize attributes. Enabling internationalization for the sensitive attribute by adding i18n-<attribute> name bypasses Angular's built-in sanitization mechanism, which when combined with a data binding to untrusted user-generated data can allow an attacker to inject a malicious script. This vulnerability is fixed in 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20.

CVSS 8.6 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • compiler

    Softwareversionen
    • >= 22.0.0-next.0, < 22.0.0-next.3: Betroffen
    • >= 21.0.0-next.0, < 21.2.4: Betroffen
    • >= 20.0.0-next.0, < 20.3.18: Betroffen
    • >= 17.0.0.next.0, < 19.2.20: Betroffen

    Keine Korrektur veröffentlicht

  • core

    Softwareversionen
    • >= 22.0.0-next.0, < 22.0.0-next.3: Betroffen
    • >= 21.0.0-next.0, < 21.2.4: Betroffen
    • >= 20.0.0-next.0, < 20.3.18: Betroffen
    • >= 17.0.0.next.0, < 19.2.20: Betroffen

    Keine Korrektur veröffentlicht

  • angular.js Debian:12

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Debian:13

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.0-next.3

    Auf 22.0.0-next.3 aktualisieren

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.4

    Auf 21.2.4 aktualisieren

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 20.0.0-next.0.0.0, < 20.3.18

    Auf 20.3.18 aktualisieren

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 19.0.0-next.0, < 19.2.20

    Auf 19.2.20 aktualisieren

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 17.0.0-next.0, ≤ 18.2.14

    Keine Korrektur veröffentlicht

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.0-next.3

    Auf 22.0.0-next.3 aktualisieren

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.4

    Auf 21.2.4 aktualisieren

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 20.0.0-next.0.0.0, < 20.3.18

    Auf 20.3.18 aktualisieren

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 19.0.0-next.0, < 19.2.20

    Auf 19.2.20 aktualisieren

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 17.0.0-next.0, ≤ 18.2.14

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:22.04:LTS

    Softwareversionen
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:24.04:LTS

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:25.10

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:26.10

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:26.04:LTS

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →