CVE-2026-32711
CVE-2026-32711 · pydicom: Path traversal in FileSet/DICOMDIR ReferencedFileID allows file access outside the File-set root
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
pydicom is a pure Python package for working with DICOM files. Versions 2.0.0-rc.1 through 3.0.1 are vulnerable to Path Traversal through a maliciously crafted DICOMDIR ReferencedFileID when it is set to a path outside the File-set root. pydicom resolves the path only to confirm that it exists, but does not verify that the resolved path remains under the File-set root. Subsequent public FileSet operations such as copy(), write(), and remove()+write(use_existing=True) use that unchecked path in file I/O operations. This allows arbitrary file read/copy and, in some flows, move/delete outside the File-set root. This issue has been fixed in version 3.0.2.
CVSS 7.8 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pydicom
- Softwareversionen
- >= 2.0.0-rc.1, < 3.0.2: Betroffen
Keine Korrektur veröffentlicht
pydicom Debian:12
- Softwareversionen
- 2.3.1-1
- 2.4.3-1
- 2.4.3-2
- 2.4.3-3
- 3.0.2-1
- 3.0.2-2
- 3.0.2-3
- 3.0.2-4
- 3.0.2-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Debian:13
- Softwareversionen
- 2.4.3-2
- 2.4.3-3
- 3.0.2-1
- 3.0.2-2
- 3.0.2-3
- 3.0.2-4
- 3.0.2-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Debian:14
- Softwareversionen
- 2.4.3-2
- 2.4.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.2-1
Auf 3.0.2-1 aktualisieren
pydicom PyPI
- Softwareversionen
- 3.0.0
- 3.0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.0.0, < 3.0.2
Auf 3.0.2 aktualisieren
pydicom PyPI
- Softwareversionen
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4-1
- 0.9.5
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- 1.0.1
- 1.0.1rc1
- 1.0.2
- 1.1.0
- 1.2.0
- 1.2.0rc1
- 1.2.1
- 1.2.2
- 1.3.0
- 1.4.0
- 1.4.0rc1
- 1.4.1
- 1.4.2
- 2.0.0
- 2.0.0rc1
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0rc1
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.5
Auf 2.4.5 aktualisieren
pydicom PyPI
- Softwareversionen
- 2.0.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0rc1
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 3.0.0
- 3.0.0rc1
- 3.0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 3.0.2
Auf 3.0.2 aktualisieren
pydicom Ubuntu:16.04:LTS
- Softwareversionen
- 0.9.8-1
- 0.9.9-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Ubuntu:18.04:LTS
- Softwareversionen
- 0.9.9-2
- 0.9.9-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Ubuntu:20.04:LTS
- Softwareversionen
- 1.2.1-1
- 1.4.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Ubuntu:22.04:LTS
- Softwareversionen
- 2.0.0-1
- 2.0.0-2
- 2.2.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Ubuntu:24.04:LTS
- Softwareversionen
- 2.3.1-1
- 2.4.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Ubuntu:25.10
- Softwareversionen
- 2.4.3-1
- 2.4.3-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Ubuntu:26.10
- Softwareversionen
- 2.4.3-3
- 3.0.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pydicom Ubuntu:26.04:LTS
- Softwareversionen
- 2.4.3-2
- 2.4.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht