CVE-2026-32794
CVE-2026-32794 · Apache Airflow Provider for Databricks: TLS Certificate Verification Disabled in Databricks Provider K8s Token Exchange
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice. This issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0. Users are recommended to upgrade to version 1.12.0, which fixes the issue.
CVSS 4.8 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
apache airflow provider for databricks
- Softwareversionen
- ≥ 1.10.0, < 1.12.0: Betroffen (semver)
Auf 1.12.0 aktualisieren
apache-airflow PyPI
- Softwareversionen
- 1.10.0
- 1.10.1
- 1.10.10
- 1.10.10rc1
- 1.10.10rc2
- 1.10.10rc3
- 1.10.10rc4
- 1.10.10rc5
- 1.10.11
- 1.10.11rc1
- 1.10.11rc2
- 1.10.12
- 1.10.12rc1
- 1.10.12rc2
- 1.10.12rc3
- 1.10.12rc4
- 1.10.13
- 1.10.13rc1
- 1.10.14
- 1.10.14rc1
- 1.10.14rc2
- 1.10.14rc3
- 1.10.14rc4
- 1.10.15
- 1.10.15rc1
- 1.10.1b1
- 1.10.1rc2
- 1.10.2
- 1.10.2b2
- 1.10.2rc1
- 1.10.2rc2
- 1.10.2rc3
- 1.10.3
- 1.10.3b1
- 1.10.3b2
- 1.10.3rc1
- 1.10.3rc2
- 1.10.4
- 1.10.4b2
- 1.10.4rc1
- 1.10.4rc2
- 1.10.4rc3
- 1.10.4rc4
- 1.10.4rc5
- 1.10.5
- 1.10.5rc1
- 1.10.6
- 1.10.6rc1
- 1.10.6rc2
- 1.10.7
- 1.10.7rc1
- 1.10.7rc2
- 1.10.7rc3
- 1.10.8
- 1.10.8rc1
- 1.10.9
- 1.10.9rc1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.10.0, < 1.12.0
Auf 1.12.0 aktualisieren