CVE-2026-33046
CVE-2026-33046 · Indico discloses local files resulting in Remote Code Execution through LaTeX injection
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. In versions prior to 3.3.12, due to vulnerabilities in TeXLive and obscure LaTeX syntax that allowed circumventing Indico's LaTeX sanitizer, it is possible to use specially-crafted LaTeX snippets which can read local files or execute code with the privileges of the user running Indico on the server. Note that if server-side LaTeX rendering is not in use (ie `XELATEX_PATH` was not set in `indico.conf`), this vulnerability does not apply. It is recommended to update to Indico 3.3.12 as soon as possible. It is also strongly recommended to enable the containerized LaTeX renderer (using `podman`), which isolates it from the rest of the system. As a workaround, remove the `XELATEX_PATH` setting from `indico.conf` (or comment it out or set it to `None`) and restart the `indico-uwsgi` and `indico-celery` services to disable LaTeX functionality.
CVSS 7.7 · Hoch · EPSS 0,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
indico
- Softwareversionen
- < 3.3.12: Betroffen
Keine Korrektur veröffentlicht
indico PyPI
- Softwareversionen
- 0.98-rc1
- 0.98.0
- 0.98.1
- 0.98.2
- 0.99
- 1.0
- 1.1
- 1.1.1
- 1.1.2
- 1.2
- 1.2.1
- 1.2.1rc10
- 1.2.1rc11
- 1.2.1rc2
- 1.2.1rc4
- 1.2.1rc5
- 1.2.1rc6
- 1.2.1rc7
- 1.2.1rc9
- 1.2.2
- 1.2.2rc1
- 1.9.11.dev10
- 1.9.11.dev11
- 1.9.11.dev12
- 1.9.11.dev13
- 1.9.11.dev14
- 1.9.11.dev15
- 1.9.11.dev16
- 1.9.11.dev17
- 1.9.11.dev3
- 1.9.11.dev4
- 1.9.11.dev6
- 1.9.11.dev7
- 1.9.11.dev8
- 1.9.11.dev9
- 2.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0a1
- 2.0rc1
- 2.0rc2
- 2.1
- 2.1.1
- 2.1.10
- 2.1.11
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.1.7
- 2.1.8
- 2.1.9
- 2.2
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.3
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 3.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0rc1
- 3.0rc2
- 3.1
- 3.1.1
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- 3.3
- 3.3.1
- 3.3.10
- 3.3.11
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.3.9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.3.12
Auf 3.3.12 aktualisieren
Originalquellen
- https://github.com/indico/indico/security/advisories/GHSA-rm2q-f7jv-3cfp
- https://github.com/indico/indico/commit/0adb70f0ed66e129361d447868f5f3eb90dc5e96
- https://github.com/indico/indico/commit/1dbb12525b3de14229bf4d1ae192988068f975f6
- https://github.com/indico/indico/commit/5f24d23ce9c4b0e4b68b3d0b58987a948fc57c8a
- https://github.com/indico/indico/commit/fb169ced710c30cf792ce4b9f48688db0633cfd8
- https://github.com/indico/indico/releases/tag/v3.3.12
- https://nvd.nist.gov/vuln/detail/CVE-2026-33046