p PatchFirst

CVE-2026-33641

CVE-2026-33641 · Glances Vulnerable to Command Injection via Dynamic Configuration Values

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.3, Glances supports dynamic configuration values in which substrings enclosed in backticks are executed as system commands during configuration parsing. This behavior occurs in Config.get_value() and is implemented without validation or restriction of the executed commands. If an attacker can modify or influence configuration files, arbitrary commands will execute automatically with the privileges of the Glances process during startup or configuration reload. In deployments where Glances runs with elevated privileges (e.g., as a system service), this may lead to privilege escalation. This issue has been patched in version 4.5.3.

CVSS 7.8 · Hoch · EPSS 0,9% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • glances

    Softwareversionen
    • < 4.5.3: Betroffen

    Keine Korrektur veröffentlicht

  • glances Debian:12

    Softwareversionen
    • 3.3.1.1+dfsg-1
    • 3.4.0.3+dfsg-1
    • 4.0.5+dfsg-1
    • 4.1.2.1+dfsg-1
    • 4.2.1+dfsg-1
    • 4.3.0.8+dfsg-1
    • 4.3.1+dfsg-1
    • 4.3.3+dfsg-1
    • 4.5.1+dfsg-1
    • 4.5.2+dfsg-1
    • 4.5.3.2+dfsg-1
    • 4.5.4+dfsg-1
    • 4.5.5+dfsg-1
    • 4.5.6+dfsg-1
    • 4.5.7+dfsg-1
    • 4.5.8+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Debian:13

    Softwareversionen
    • 4.3.1+dfsg-1
    • 4.3.3+dfsg-1
    • 4.5.1+dfsg-1
    • 4.5.2+dfsg-1
    • 4.5.3.2+dfsg-1
    • 4.5.4+dfsg-1
    • 4.5.5+dfsg-1
    • 4.5.6+dfsg-1
    • 4.5.7+dfsg-1
    • 4.5.8+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Debian:14

    Softwareversionen
    • 4.3.1+dfsg-1
    • 4.3.3+dfsg-1
    • 4.5.1+dfsg-1
    • 4.5.2+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.5.3.2+dfsg-1

    Auf 4.5.3.2+dfsg-1 aktualisieren

  • glances PyPI

    Softwareversionen
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.3.5
    • 1.3.6
    • 1.3.7
    • 1.4
    • 1.4.1
    • 1.4.1.1
    • 1.4.2
    • 1.4.2.1
    • 1.5
    • 1.5.1
    • 1.5.2
    • 1.6
    • 1.6.1
    • 1.7
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 1.7.5
    • 1.7.6
    • 1.7.7
    • 2.0
    • 2.0.1
    • 2.1
    • 2.1.1
    • 2.1.2
    • 2.10
    • 2.11
    • 2.11.1
    • 2.2
    • 2.2.1
    • 2.3
    • 2.4
    • 2.4.1
    • 2.4.2
    • 2.5
    • 2.5.1
    • 2.6
    • 2.6.1
    • 2.6.2
    • 2.7
    • 2.7.1
    • 2.8
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.8.4
    • 2.8.5
    • 2.8.6
    • 2.8.7
    • 2.8.8
    • 2.9.0
    • 2.9.1
    • 3.0
    • 3.0.1
    • 3.0.2
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.1.4
    • 3.1.4.1
    • 3.1.5
    • 3.1.6
    • 3.1.6.1
    • 3.1.6.2
    • 3.1.7
    • 3.2.0
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.3.1
    • 3.2.4
    • 3.2.4.1
    • 3.2.4.2
    • 3.2.5
    • 3.2.6.1
    • 3.2.6.2
    • 3.2.6.3
    • 3.2.6.4
    • 3.2.7
    • 3.3.0
    • 3.3.0.1
    • 3.3.0.2
    • 3.3.0.3
    • 3.3.0.4
    • 3.3.1
    • 3.3.1.1
    • 3.4.0
    • 3.4.0.1
    • 3.4.0.2
    • 3.4.0.3
    • 3.4.0.4
    • 3.4.0.5
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.5
    • 4.0.6
    • 4.0.7
    • 4.0.8
    • 4.1.0
    • 4.1.1
    • 4.1.2
    • 4.2.0
    • 4.2.1
    • 4.3.0
    • 4.3.0.1
    • 4.3.0.3
    • 4.3.0.4
    • 4.3.0.5
    • 4.3.0.6
    • 4.3.0.7
    • 4.3.0.8
    • 4.3.1
    • 4.3.2
    • 4.3.3
    • 4.4.0
    • 4.4.1
    • 4.5.0
    • 4.5.0.1
    • 4.5.0.2
    • 4.5.0.3
    • 4.5.0.4
    • 4.5.0.5
    • 4.5.1
    • 4.5.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.5.3

    Auf 4.5.3 aktualisieren

  • glances Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2.3-1build1
    • 2.3-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 2.10-2
    • 2.11.1-1
    • 2.11.1-2
    • 2.11.1-3
    • 2.11.1-3ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 3.1.0-1
    • 3.1.1-1
    • 3.1.3-1
    • 3.1.3-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Ubuntu:22.04:LTS

    Softwareversionen
    • 3.1.5-1
    • 3.2.3.1+dfsg-1
    • 3.2.4.2+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Ubuntu:24.04:LTS

    Softwareversionen
    • 3.4.0.3+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Ubuntu:25.10

    Softwareversionen
    • 4.3.0.8+dfsg-1
    • 4.3.1+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Ubuntu:26.10

    Softwareversionen
    • 4.3.3+dfsg-1
    • 4.5.4+dfsg-1
    • 4.5.5+dfsg-1
    • 4.5.6+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glances Ubuntu:26.04:LTS

    Softwareversionen
    • 4.3.1+dfsg-1
    • 4.3.3+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →