CVE-2026-33709
CVE-2026-33709 · JupyterHub has an Open Redirect Vulnerability
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to version 5.4.4, an open redirect vulnerability in JupyterHub allows attackers to construct links which, when clicked, take users to the JupyterHub login page, after which they are sent to an arbitrary attacker-controlled site outside JupyterHub instead of a JupyterHub page, bypassing JupyterHub's check to prevent this. This issue has been patched in version 5.4.4.
CVSS 5.1 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
jupyterhub
- Softwareversionen
- < 5.4.4: Betroffen
Keine Korrektur veröffentlicht
jupyterhub Debian:12
- Softwareversionen
- 3.0.0+ds1-1
- 5.0.0+ds1-1
- 5.0.0+ds1-2
- 5.0.0+ds1-3
- 5.0.0+ds1-4
- 5.2.1+ds1-1
- 5.2.1+ds1-2
- 5.2.1+ds1-3
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Debian:13
- Softwareversionen
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Debian:14
- Softwareversionen
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub PyPI
- Softwareversionen
- 0.1.0
- 0.2.0
- 0.3.0
- 0.4.0
- 0.4.1
- 0.5.0
- 0.6.0
- 0.6.1
- 0.7.0
- 0.7.0b1
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.0b1
- 0.8.0b2
- 0.8.0b3
- 0.8.0b4
- 0.8.0b5
- 0.8.0rc1
- 0.8.0rc2
- 0.8.1
- 0.9.0
- 0.9.0b1
- 0.9.0b2
- 0.9.0b3
- 0.9.0rc1
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 1.0.0
- 1.0.0b1
- 1.0.0b2
- 1.1.0
- 1.1.0b1
- 1.2.0
- 1.2.0b1
- 1.2.1
- 1.2.2
- 1.3.0
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 3.0.0
- 3.0.0b1
- 3.1.0
- 3.1.1
- 4.0.0
- 4.0.0b1
- 4.0.0b2
- 4.0.1
- 4.0.2
- 4.1.0
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 5.0.0
- 5.0.0b1
- 5.0.0b2
- 5.1.0
- 5.2.0
- 5.2.1
- 5.3.0
- 5.3.0rc0
- 5.4.0
- 5.4.1
- 5.4.2
- 5.4.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.4
Auf 5.4.4 aktualisieren
jupyterhub Ubuntu:22.04:LTS
- Softwareversionen
- 2.0.0+ds1-1
- 2.0.0+ds1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Ubuntu:24.04:LTS
- Softwareversionen
- 3.0.0+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Ubuntu:25.10
- Softwareversionen
- 5.2.1+ds1-2
- 5.2.1+ds1-3
- 5.2.1+ds1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Ubuntu:26.10
- Softwareversionen
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Ubuntu:26.04:LTS
- Softwareversionen
- 5.2.1+ds1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht