CVE-2026-34543
CVE-2026-34543 · OpenEXR: Heap information disclosure in PXR24 decompression via unchecked decompressed size (undo_pxr24_impl)
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From version 3.4.0 to before version 3.4.8, sensitive information from heap memory may be leaked through the decoded pixel data (information disclosure). This occurs under default settings; simply reading a malicious EXR file is sufficient to trigger the issue, without any user interaction. This issue has been patched in version 3.4.8.
CVSS 8.7 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
openexr
- Softwareversionen
- >= 3.4.0, < 3.4.8: Betroffen
Keine Korrektur veröffentlicht
openexr Debian:12
- Softwareversionen
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Debian:13
- Softwareversionen
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Debian:14
- Softwareversionen
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.4.14-0.1
Auf 3.4.14-0.1 aktualisieren
openexr PyPI
- Softwareversionen
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.4.0, < 3.4.8
Auf 3.4.8 aktualisieren
openexr PyPI
- Softwareversionen
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.3.0, ≤ 3.3.8
Keine Korrektur veröffentlicht
openexr PyPI
- Softwareversionen
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.2.0, ≤ 3.2.6
Keine Korrektur veröffentlicht
openexr PyPI
- Softwareversionen
- 3.2.10
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- 3.3.0
- 3.3.1
- 3.3.10
- 3.3.11
- 3.3.12
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.3.9
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.2.0, < 3.4.8
Auf 3.4.8 aktualisieren
openexr Ubuntu:26.10
- Softwareversionen
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-vc68-257w-m432
- https://github.com/AcademySoftwareFoundation/openexr/commit/5f6d0aaa9e43802917af7db90f181e88e083d3b8
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.8
- https://nvd.nist.gov/vuln/detail/CVE-2026-34543