CVE-2026-34571
CVE-2026-34571 · CI4MS: Stored Cross‑Site Scripting (Stored XSS) in Backend User Management Allows Session Hijacking and Full Administrative Account Compromise
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, a Stored Cross-Site Scripting (Stored XSS) vulnerability exists in the backend user management functionality. The application fails to properly sanitize user-controlled input before rendering it in the administrative interface, allowing attackers to inject persistent JavaScript code. This results in automatic execution whenever backend users access the affected page, enabling session hijacking, privilege escalation, and full administrative account compromise. This issue has been patched in version 0.31.0.0.
CVSS 10.0 · Kritisch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: php
Betroffene Produkte und Versionen
ci4ms
- Softwareversionen
- < 0.31.0.0: Betroffen
Keine Korrektur veröffentlicht
ci4-cms-erp/ci4ms Packagist
- Softwareversionen
- 0.21.0
- 0.21.1
- 0.21.2
- 0.21.3
- 0.21.3.1
- 0.21.3.2
- 0.21.3.3
- 0.21.3.4
- 0.21.3.5
- 0.21.3.6
- 0.21.3.7
- 0.23.0.0
- 0.23.0.1
- 0.23.0.2
- 0.23.1.0
- 0.24.0.0
- 0.24.0.16
- 0.24.0.18
- 0.24.0.19
- 0.24.0.20
- 0.24.0.27
- 0.24.0.42
- 0.24.0.45
- 0.24.0.60
- 0.25.0.0
- 0.25.0.1
- 0.25.0.2
- 0.25.0.30
- 0.25.0.39
- 0.25.0.43
- 0.25.1.0
- 0.25.2.0
- 0.25.3.0
- 0.26.0.0
- 0.26.1.0
- 0.26.2.0
- 0.26.3.0
- 0.26.3.1
- 0.26.3.2
- 0.26.3.3
- 0.26.3.4
- 0.27.0.0
- 0.28.0.0
- 0.28.3.0
- 0.28.4.0
- 0.28.5.0
- 0.28.6.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.31.0.0
Auf 0.31.0.0 aktualisieren