CVE-2026-34588
CVE-2026-34588 · OpenEXR has a signed 32-bit Overflow in PIZ Decoder Leads to OOB Read/Write
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.1.0 to before 3.2.7, 3.3.9, and 3.4.9, internal_exr_undo_piz() advances the working wavelet pointer with signed 32-bit arithmetic. Because nx, ny, and wcount are int, a crafted EXR file can make this product overflow and wrap. The next channel then decodes from an incorrect address. The wavelet decode path operates in place, so this yields both out-of-bounds reads and out-of-bounds writes. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.
CVSS 8.6 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
openexr
- Softwareversionen
- >= 3.1.0, <= 3.1.13: Betroffen
- >= 3.2.0, < 3.2.7: Betroffen
- >= 3.3.0, < 3.3.9: Betroffen
- >= 3.4.0, < 3.4.9: Betroffen
Keine Korrektur veröffentlicht
openexr Debian:12
- Softwareversionen
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Debian:13
- Softwareversionen
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Debian:14
- Softwareversionen
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.4.14-0.1
Auf 3.4.14-0.1 aktualisieren
openexr PyPI
- Softwareversionen
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.1.0, < 3.2.7
Auf 3.2.7 aktualisieren
openexr PyPI
- Softwareversionen
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.3.0, < 3.3.9
Auf 3.3.9 aktualisieren
openexr PyPI
- Softwareversionen
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- 3.4.8
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.4.0, < 3.4.9
Auf 3.4.9 aktualisieren
openexr PyPI
- Softwareversionen
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- 3.4.8
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.1.0, < 3.2.7 ∪ ≥ 3.3.0, < 3.3.9 ∪ ≥ 3.4.0, < 3.4.9
Auf 3.2.7 aktualisieren; Auf 3.3.9 aktualisieren; Auf 3.4.9 aktualisieren
openexr Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 3.1.5-5.1
- 3.1.5-5.1build1
- 3.1.5-5.1build2
- 3.1.5-5.1build3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.5-5.1ubuntu0.1~esm1
Auf 3.1.5-5.1ubuntu0.1~esm1 aktualisieren
openexr Ubuntu:25.10
- Softwareversionen
- 3.1.13-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Ubuntu:26.10
- Softwareversionen
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openexr Ubuntu:Pro:26.04:LTS
- Softwareversionen
- 3.1.13-2
- 3.1.13-2build1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.13-2ubuntu0.26.04.1~esm1
Auf 3.1.13-2ubuntu0.26.04.1~esm1 aktualisieren
Originalquellen
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-588r-cr5c-w6hf
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.2.7
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.3.9
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.9
- https://access.redhat.com/security/cve/CVE-2026-34588
- https://bugzilla.redhat.com/show_bug.cgi?id=2455408
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34588.json
- https://access.redhat.com/errata/RHSA-2026:17656
- https://access.redhat.com/errata/RHSA-2026:15888
- https://access.redhat.com/errata/RHSA-2026:19146
- https://access.redhat.com/errata/RHSA-2026:19587
- https://access.redhat.com/errata/RHSA-2026:17659
- https://access.redhat.com/errata/RHSA-2026:17658
- https://access.redhat.com/errata/RHSA-2026:17660
- https://access.redhat.com/errata/RHSA-2026:15887
- https://access.redhat.com/errata/RHSA-2026:19359
- https://access.redhat.com/errata/RHSA-2026:30078
- https://access.redhat.com/errata/RHSA-2026:30089
- https://access.redhat.com/errata/RHSA-2026:30088
- https://access.redhat.com/errata/RHSA-2026:30087
- https://nvd.nist.gov/vuln/detail/CVE-2026-34588