p PatchFirst

CVE-2026-34589

CVE-2026-34589 · OpenEXR: DWA Lossy Decoder Heap Out-of-Bounds Write

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, the DWA lossy decoder constructs temporary per-component block pointers using signed 32-bit arithmetic. For a large enough width, the calculation overflows and later decoder stores operate on a wrapped pointer outside the allocated rowBlock backing store. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.

CVSS 8.4 · Hoch · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • openexr

    Softwareversionen
    • >= 3.2.0, < 3.2.7: Betroffen
    • >= 3.3.0, < 3.3.9: Betroffen
    • >= 3.4.0, < 3.4.9: Betroffen

    Keine Korrektur veröffentlicht

  • openexr Debian:12

    Softwareversionen
    • 3.1.13-1
    • 3.1.13-2
    • 3.1.5-5
    • 3.1.5-5.1
    • 3.1.5-5.1+hurd.1
    • 3.4.14-0.1
    • 3.4.15+ds-1
    • 3.4.16+ds-1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    • 3.5.2+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Debian:13

    Softwareversionen
    • 3.1.13-2
    • 3.4.14-0.1
    • 3.4.15+ds-1
    • 3.4.16+ds-1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    • 3.5.2+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Debian:14

    Softwareversionen
    • 3.1.13-2
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.14-0.1

    Auf 3.4.14-0.1 aktualisieren

  • openexr PyPI

    Softwareversionen
    • 3.2.3
    • 3.2.4
    • 3.2.5
    • 3.2.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.2.0, < 3.2.7

    Auf 3.2.7 aktualisieren

  • openexr PyPI

    Softwareversionen
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    • 3.3.5
    • 3.3.6
    • 3.3.7
    • 3.3.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.3.0, < 3.3.9

    Auf 3.3.9 aktualisieren

  • openexr PyPI

    Softwareversionen
    • 3.4.0
    • 3.4.1
    • 3.4.2
    • 3.4.3
    • 3.4.4
    • 3.4.5
    • 3.4.6
    • 3.4.7
    • 3.4.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.4.0, < 3.4.9

    Auf 3.4.9 aktualisieren

  • openexr PyPI

    Softwareversionen
    • 3.2.3
    • 3.2.4
    • 3.2.5
    • 3.2.6
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    • 3.3.5
    • 3.3.6
    • 3.3.7
    • 3.3.8
    • 3.4.0
    • 3.4.1
    • 3.4.2
    • 3.4.3
    • 3.4.4
    • 3.4.5
    • 3.4.6
    • 3.4.7
    • 3.4.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.2.0, < 3.2.7 ∪ ≥ 3.3.0, < 3.3.9 ∪ ≥ 3.4.0, < 3.4.9

    Auf 3.2.7 aktualisieren; Auf 3.3.9 aktualisieren; Auf 3.4.9 aktualisieren

  • openexr Ubuntu:26.10

    Softwareversionen
    • 3.1.13-2build1
    • 3.4.6+ds-4ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →