p PatchFirst

CVE-2026-39983

CVE-2026-39983 · FTP Command Injection via CRLF in basic-ftp

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

basic-ftp is an FTP client for Node.js. Prior to 5.2.1, basic-ftp allows FTP command injection via CRLF sequences (\r\n) in file path parameters passed to high-level path APIs such as cd(), remove(), rename(), uploadFrom(), downloadTo(), list(), and removeDir(). The library's protectWhitespace() helper only handles leading spaces and returns other paths unchanged, while FtpContext.send() writes the resulting command string directly to the control socket with \r\n appended. This lets attacker-controlled path strings split one intended FTP command into multiple commands. This vulnerability is fixed in 5.2.1.

CVSS 8.6 · Hoch · EPSS 2,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • basic-ftp

    Softwareversionen
    • < 5.2.1: Betroffen

    Keine Korrektur veröffentlicht

  • node-proxy-agents Debian:13

    Softwareversionen
    • 0~2024040606-6
    • 0~2024040606-6+deb13u1
    • 0~2025070717+~cs15.2.7-1
    • 0~2025070717+~cs15.3.7-1
    • 0~2025070717+~cs15.3.8-1
    • 0~2025070717+~cs15.3.8-2
    • 0~2025070717+~cs15.3.8-3
    • 0~2025070717+~cs16.2.9-1
    • 0~2025070717-1
    • 0~2025070717-2
    • 0~2025070717-3
    • 0~2025070717-4
    • 0~2025070717-5
    • 0~2025070717-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-proxy-agents Debian:14

    Softwareversionen
    • 0~2024040606-6
    • 0~2025070717+~cs15.2.7-1
    • 0~2025070717-1
    • 0~2025070717-2
    • 0~2025070717-3
    • 0~2025070717-4
    • 0~2025070717-5
    • 0~2025070717-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0~2025070717+~cs15.3.7-1

    Auf 0~2025070717+~cs15.3.7-1 aktualisieren

  • basic-ftp npm

    Softwareversionen
    • 5.2.0
    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.2.0, < 5.2.1

    Auf 5.2.1 aktualisieren

  • node-proxy-agents Ubuntu:24.04:LTS

    Softwareversionen
    • 0~2023071921-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-proxy-agents Ubuntu:25.10

    Softwareversionen
    • 0~2024040606-5
    • 0~2024040606-6
    • 0~2025070717-1
    • 0~2025070717-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-proxy-agents Ubuntu:26.10

    Softwareversionen
    • 0~2025070717+~cs15.2.7-1build1
    • 0~2025070717+~cs15.3.8-1
    • 0~2025070717+~cs15.3.8-2
    • 0~2025070717+~cs15.3.8-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-proxy-agents Ubuntu:26.04:LTS

    Softwareversionen
    • 0~2025070717-2
    • 0~2025070717-6
    • 0~2025070717+~cs15.2.7-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →