CVE-2026-40295
CVE-2026-40295 · Devise: Open Redirect via Unvalidated `request.referrer` in Timeoutable Session Timeout Handler
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Devise is an authentication solution for Rails based on Warden. In versions 5.0.3 and below, when the Timeoutable module is enabled in Devise, the FailureApp#redirect_url method returns request.referrer — the HTTP Referer header, which is attacker-controllable — without validation for any non-GET request that results in a session timeout. An attacker who hosts a page with an auto-submitting cross-origin form can cause a victim with an expired Devise session to be redirected to an arbitrary external URL. This contrasts with the GET timeout path (which uses server-side attempted_path) and Devise's own store_location_for mechanism (which strips external hosts via extract_path_from_location), both of which are protected; only the non-GET timeout redirect path is unprotected. Expired-session users can be silently redirected from the trusted app domain to attacker-controlled URLs, enabling phishing and malware delivery while bypassing browser warnings. Note: Rails' built-in open-redirect protection does not mitigate this issue. Devise::FailureApp is an ActionController::Metal app with its own isolated copy of the relevant redirect configuration, so config.action_controller.action_on_open_redirect = :raise (and the older raise_on_open_redirects setting) do not reach it. This issue has been fixed in version 5.0.4.
CVSS 6.1 · Mittel · EPSS 0,2%
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
devise
- Softwareversionen
- < 5.0.4: Betroffen
Keine Korrektur veröffentlicht
ruby-devise Debian:12
- Softwareversionen
- 4.8.1-1
- 4.9.2-1
- 4.9.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby-devise Ubuntu:16.04:LTS
- Softwareversionen
- 3.5.1-1
- 3.5.2-1
- 3.5.2-2
- 3.5.2-3
- 3.5.6-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby-devise Ubuntu:18.04:LTS
- Softwareversionen
- 4.2.0-1
- 4.3.0-1
- 4.4.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby-devise Ubuntu:20.04:LTS
- Softwareversionen
- 4.5.0-3
- 4.6.2-2
- 4.7.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby-devise Ubuntu:22.04:LTS
- Softwareversionen
- 4.7.3-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby-devise Ubuntu:24.04:LTS
- Softwareversionen
- 4.8.1-1
- 4.9.2-1
- 4.9.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht