p PatchFirst

CVE-2026-41672

CVE-2026-41672 · xmldom: XML node injection through unvalidated comment serialization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In @xmldom/xmldom prior to versions 0.9.10 and 0.8.13 and xmldom version 0.6.0 and prior, the package allows attacker-controlled comment content to be serialized into XML without validating or neutralizing comment-breaking sequences. As a result, an attacker can terminate the comment early and inject arbitrary XML nodes into the serialized output. This issue has been patched in versions @xmldom/xmldom versions 0.9.10 and 0.8.13.

CVSS 8.7 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • xmldom

    Softwareversionen
    • xmldom <= 0.6.0: Betroffen
    • @xmldom/xmldom >= 0.9.0, < 0.9.10: Betroffen
    • @xmldom/xmldom < 0.8.13: Betroffen

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:12

    Softwareversionen
    • 0.8.6-1
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.12-1
    • 0.9.5-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:13

    Softwareversionen
    • 0.9.10-1
    • 0.9.10-2
    • 0.9.11-1
    • 0.9.12-1
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Debian:14

    Softwareversionen
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    • 0.9.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.9.10-1

    Auf 0.9.10-1 aktualisieren

  • @xmldom/xmldom npm

    Betroffene Versionsbereiche
    • SEMVER: < 0.8.13

    Auf 0.8.13 aktualisieren

  • @xmldom/xmldom npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.9.0, < 0.9.10

    Auf 0.9.10 aktualisieren

  • xmldom npm

    Betroffene Versionsbereiche
    • SEMVER: ≤ 0.6.0

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:20.04:LTS

    Softwareversionen
    • 0.1.27+ds-1
    • 0.1.27+ds-1+deb10u2build0.20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:22.04:LTS

    Softwareversionen
    • 0.5.0-1
    • 0.7.3-1
    • 0.7.5-1
    • 0.7.5-1ubuntu0.22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:24.04:LTS

    Softwareversionen
    • 0.8.6-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:25.10

    Softwareversionen
    • 0.9.6-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:26.10

    Softwareversionen
    • 0.9.8-2
    • 0.9.10-2
    • 0.9.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-xmldom Ubuntu:26.04:LTS

    Softwareversionen
    • 0.9.6-1
    • 0.9.8-1
    • 0.9.8-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →