CVE-2026-41907
CVE-2026-41907 · uuid: Missing buffer bounds check in `v3`/`v5`/`v6` when `buf` is provided
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
uuid is for the creation of RFC9562 (formerly RFC4122) UUIDs. Prior to 14.0.0, v3, v5, and v6 accept external output buffers but do not reject out-of-range writes (small buf or large offset). This allows silent partial writes into caller-provided buffers. This vulnerability is fixed in 14.0.0.
CVSS 8.1 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
uuid
- Softwareversionen
- < 14.0.0: Betroffen
Keine Korrektur veröffentlicht
node-uuid Debian:12
- Softwareversionen
- 14.0.0+~11.0.0-1
- 14.0.1-1
- 14.0.2-1
- 14.0.3-1
- 14.0.3-2
- 8.3.2+~8.3.3-3
- 8.3.2+~8.3.3-4
- 8.3.2+~8.3.4-1
- 8.3.2+~8.3.4-2
- 8.3.2+~8.3.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Debian:13
- Softwareversionen
- 14.0.0+~11.0.0-1
- 14.0.1-1
- 14.0.2-1
- 14.0.3-1
- 14.0.3-2
- 8.3.2+~8.3.4-1
- 8.3.2+~8.3.4-2
- 8.3.2+~8.3.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Debian:14
- Softwareversionen
- 8.3.2+~8.3.4-1
- 8.3.2+~8.3.4-2
- 8.3.2+~8.3.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 14.0.0+~11.0.0-1
Auf 14.0.0+~11.0.0-1 aktualisieren
uuid npm
- Betroffene Versionsbereiche
- SEMVER: < 11.1.1
Auf 11.1.1 aktualisieren
uuid npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 12.0.0, < 12.0.1
Auf 12.0.1 aktualisieren
uuid npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 13.0.0, < 13.0.1
Auf 13.0.1 aktualisieren
node-uuid Ubuntu:14.04:LTS
- Softwareversionen
- 1.3.3-2
- 1.4.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Ubuntu:16.04:LTS
- Softwareversionen
- 1.4.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Ubuntu:18.04:LTS
- Softwareversionen
- 1.4.0-1
- 1.4.7-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Ubuntu:20.04:LTS
- Softwareversionen
- 3.3.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Ubuntu:22.04:LTS
- Softwareversionen
- 8.3.2+~8.3.0-4
- 8.3.2+~8.3.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Ubuntu:24.04:LTS
- Softwareversionen
- 8.3.2+~8.3.3-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Ubuntu:25.10
- Softwareversionen
- 8.3.2+~8.3.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Ubuntu:26.10
- Softwareversionen
- 8.3.2+~8.3.4-3
- 14.0.0+~11.0.0-1
- 14.0.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-uuid Ubuntu:26.04:LTS
- Softwareversionen
- 8.3.2+~8.3.4-1
- 8.3.2+~8.3.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht