p PatchFirst

CVE-2026-42041

CVE-2026-42041 · Axios: Authentication Bypass via Prototype Pollution Gadget in `validateStatus` Merge Strategy

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.1 and 0.31.1, the Axios library is vulnerable to a Prototype Pollution "Gadget" attack that allows any Object.prototype pollution to silently suppress all HTTP error responses (401, 403, 500, etc.), causing them to be treated as successful responses. This completely bypasses application-level authentication and error handling. The root cause is that validateStatus is the only config property using the mergeDirectKeys merge strategy, which uses JavaScript's in operator — an operator that inherently traverses the prototype chain. When Object.prototype.validateStatus is polluted with () => true, all HTTP status codes are accepted as success. This vulnerability is fixed in 1.15.1 and 0.31.1.

CVSS 4.8 · Mittel · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • axios

    Softwareversionen
    • >= 1.0.0, < 1.15.1: Betroffen
    • < 0.31.1: Betroffen

    Keine Korrektur veröffentlicht

  • node-axios Debian:12

    Softwareversionen
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.15.2-1
    • 1.16.0-1
    • 1.18.0-1
    • 1.19.0-1
    • 1.2.1+dfsg-1
    • 1.2.1+dfsg-1+deb12u1
    • 1.20.0-1
    • 1.5.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.8+dfsg-1
    • 1.6.8+dfsg-2
    • 1.7.3+dfsg-1
    • 1.7.4+dfsg-1
    • 1.7.7+dfsg-1
    • 1.7.9+dfsg-1
    • 1.8.4+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Debian:13

    Softwareversionen
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.15.2-1
    • 1.16.0-1
    • 1.18.0-1
    • 1.19.0-1
    • 1.20.0-1
    • 1.8.4+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Debian:14

    Softwareversionen
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.8.4+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.15.2-1

    Auf 1.15.2-1 aktualisieren

  • axios npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.0.0, < 1.15.1

    Auf 1.15.1 aktualisieren

  • axios npm

    Betroffene Versionsbereiche
    • SEMVER: < 0.31.1

    Auf 0.31.1 aktualisieren

  • node-axios Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 0.19.0+dfsg-2
    • 0.19.0+dfsg-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 0.21.1+dfsg-1
    • 0.23.0+dfsg-2
    • 0.24.0+dfsg-1
    • 0.25.0+dfsg-2
    • 0.26.0+dfsg-1
    • 0.26.0+dfsg-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 1.2.1+dfsg-1
    • 1.5.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.8+dfsg-2
    • 1.6.8+dfsg-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:25.10

    Softwareversionen
    • 1.7.9+dfsg-1
    • 1.8.4+dfsg-1
    • 1.11.0+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:26.10

    Softwareversionen
    • 1.13.2+dfsg-1build1
    • 1.16.0-1
    • 1.18.0-1
    • 1.19.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:Pro:26.04:LTS

    Softwareversionen
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.2+dfsg-1build1
    • 1.13.2+dfsg-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →