p PatchFirst

CVE-2026-42215

CVE-2026-42215 · GitPython: Command injection via Git options bypass

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

GitPython is a python library used to interact with Git repositories. From version 3.1.30 to before version 3.1.47, GitPython blocks dangerous Git options such as --upload-pack and --receive-pack by default, but the equivalent Python kwargs upload_pack and receive_pack bypass that check. If an application passes attacker-controlled kwargs into Repo.clone_from(), Remote.fetch(), Remote.pull(), or Remote.push(), this leads to arbitrary command execution even when allow_unsafe_options is left at its default value of False. This issue has been patched in version 3.1.47.

CVSS 8.8 · Hoch · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • gitpython

    Softwareversionen
    • >= 3.1.30, < 3.1.47: Betroffen

    Keine Korrektur veröffentlicht

  • python-git Debian:12

    Softwareversionen
    • 3.1.30-1
    • 3.1.30-1+deb12u2
    • 3.1.36-1
    • 3.1.37-1
    • 3.1.37-2
    • 3.1.37-3
    • 3.1.44-1
    • 3.1.45-1
    • 3.1.46-1
    • 3.1.50-1
    • 3.1.61-1
    • 3.1.62-1
    • 3.1.62-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-git Debian:13

    Softwareversionen
    • 3.1.44-1
    • 3.1.45-1
    • 3.1.46-1
    • 3.1.50-1
    • 3.1.61-1
    • 3.1.62-1
    • 3.1.62-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-git Debian:14

    Softwareversionen
    • 3.1.44-1
    • 3.1.45-1
    • 3.1.46-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.50-1

    Auf 3.1.50-1 aktualisieren

  • gitpython PyPI

    Softwareversionen
    • 3.1.30
    • 3.1.31
    • 3.1.32
    • 3.1.33
    • 3.1.34
    • 3.1.35
    • 3.1.36
    • 3.1.37
    • 3.1.38
    • 3.1.40
    • 3.1.41
    • 3.1.42
    • 3.1.43
    • 3.1.44
    • 3.1.45
    • 3.1.46
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.1.30, < 3.1.47

    Auf 3.1.47 aktualisieren

  • python-git Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 0.3.2~RC1-2
    • 0.3.2~RC1-3
    • 0.3.2~RC1-3ubuntu0.1~esm1
    • 0.3.2~RC1-3ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.3.2~RC1-3ubuntu0.1~esm3

    Auf 0.3.2~RC1-3ubuntu0.1~esm3 aktualisieren

  • python-git Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.0.1+git137-gc8b8379-1
    • 1.0.1+git137-gc8b8379-2
    • 1.0.1+git137-gc8b8379-2.1
    • 1.0.1+git137-gc8b8379-2.1ubuntu0.1~esm1
    • 1.0.1+git137-gc8b8379-2.1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.1+git137-gc8b8379-2.1ubuntu0.1~esm4

    Auf 1.0.1+git137-gc8b8379-2.1ubuntu0.1~esm4 aktualisieren

  • python-git Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 2.1.5-1
    • 2.1.6-1
    • 2.1.7-1
    • 2.1.8-1
    • 2.1.8-1ubuntu0.1~esm1
    • 2.1.8-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.8-1ubuntu0.1~esm4

    Auf 2.1.8-1ubuntu0.1~esm4 aktualisieren

  • python-git Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 2.1.11-1
    • 3.0.4-1
    • 3.0.5-1
    • 3.0.7-1
    • 3.0.7-1ubuntu0.1~esm1
    • 3.0.7-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.7-1ubuntu0.1~esm4

    Auf 3.0.7-1ubuntu0.1~esm4 aktualisieren

  • python-git Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 3.1.14-1
    • 3.1.23-1
    • 3.1.24-1
    • 3.1.24-1ubuntu0.1~esm1
    • 3.1.24-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.24-1ubuntu0.1~esm3

    Auf 3.1.24-1ubuntu0.1~esm3 aktualisieren

  • python-git Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 3.1.30-1
    • 3.1.37-1
    • 3.1.37-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.37-3ubuntu0.1~esm2

    Auf 3.1.37-3ubuntu0.1~esm2 aktualisieren

  • python-git Ubuntu:25.10

    Softwareversionen
    • 3.1.44-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-git Ubuntu:26.10

    Softwareversionen
    • 3.1.46-1
    • 3.1.50-1
    • 3.1.61-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python-git Ubuntu:Pro:26.04:LTS

    Softwareversionen
    • 3.1.44-1
    • 3.1.45-1
    • 3.1.46-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.46-1ubuntu0.1~esm1

    Auf 3.1.46-1ubuntu0.1~esm1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →