p PatchFirst

CVE-2026-42256

CVE-2026-42256 · net-imap: Denial of service via high iteration count for `SCRAM-*` authentication

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. From versions 0.4.0 to before 0.4.24, 0.5.0 to before 0.5.14, and 0.6.0 to before 0.6.4, when authenticating a connection with SCRAM-SHA1 or SCRAM-SHA256, a hostile server can perform a computational denial-of-service attack on the client process by sending a big iteration count value. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

CVSS 6.0 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • net-imap

    Softwareversionen
    • >= 0.4.0, < 0.4.24: Betroffen
    • >= 0.5.0, < 0.5.14: Betroffen
    • >= 0.6.0, < 0.6.4: Betroffen

    Keine Korrektur veröffentlicht

  • ruby3.1 Debian:12

    Softwareversionen
    • 3.1.2-7
    • 3.1.2-7+deb12u1
    • 3.1.2-7+hurd.1
    • 3.1.2-8
    • 3.1.2-8.1~exp1
    • 3.1.2-8.3
    • 3.1.2-8.4
    • 3.1.2-8.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby3.3 Debian:13

    Softwareversionen
    • 3.3.8-2
    • 3.3.8-2.1
    • 3.3.8-2.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby3.3 Debian:14

    Softwareversionen
    • 3.3.8-2
    • 3.3.8-2.1
    • 3.3.8-2.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jruby Ubuntu:25.10

    Softwareversionen
    • 9.4.8.0+ds-2ubuntu1
    • 9.4.8.0+ds-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby3.3 Ubuntu:25.10

    Softwareversionen
    • 3.3.7-1ubuntu2
    • 3.3.8-2ubuntu1
    • 3.3.8-2ubuntu2
    • 3.3.8-2ubuntu2.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jruby Ubuntu:26.10

    Softwareversionen
    • 9.4.8.0+ds-3ubuntu1
    • 9.4.14.0+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby3.3 Ubuntu:26.04:LTS

    Softwareversionen
    • 3.3.8-2ubuntu2
    • 3.3.8-2ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.8-2ubuntu3.1

    Auf 3.3.8-2ubuntu3.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →