CVE-2026-42266
CVE-2026-42266 · JupyterLab has an Extension Manager API/GUI Policy Discrepancy allowing 3rd party (malicious) extensions install via POST request.
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.
CVSS 8.8 · Hoch · EPSS 5,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
jupyterlab
- Softwareversionen
- >= 4.0.0, < 4.5.7: Betroffen
Keine Korrektur veröffentlicht
jupyterlab Debian:13
- Softwareversionen
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- 4.0.11+ds2+~cs11.25.27-1
- 4.0.11+ds2+~cs11.25.27-3
- 4.0.11+ds3+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-2
- 4.0.11+ds4+~cs11.25.27-3
- 4.0.11+ds4+~cs11.25.27-4
- 4.0.11+ds5+~cs11.25.27-1
- 4.0.13+ds1+~2.0.1+~cs1.4.4-1
- 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
- 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6
- 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterlab Debian:14
- Softwareversionen
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- 4.0.11+ds2+~cs11.25.27-1
- 4.0.11+ds2+~cs11.25.27-3
- 4.0.11+ds3+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-2
- 4.0.11+ds4+~cs11.25.27-3
- 4.0.11+ds4+~cs11.25.27-4
- 4.0.11+ds5+~cs11.25.27-1
- 4.0.13+ds1+~2.0.1+~cs1.4.4-1
- 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
- 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
- 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
Auf 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3 aktualisieren
jupyterlab PyPI
- Softwareversionen
- 4.0.0
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.12
- 4.0.13
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.0a1
- 4.1.0a2
- 4.1.0a3
- 4.1.0a4
- 4.1.0b0
- 4.1.0b1
- 4.1.0b2
- 4.1.0rc0
- 4.1.0rc1
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.2.0
- 4.2.0a0
- 4.2.0a1
- 4.2.0a2
- 4.2.0b0
- 4.2.0b1
- 4.2.0b2
- 4.2.0b3
- 4.2.0rc0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.3.0
- 4.3.0a0
- 4.3.0a1
- 4.3.0a2
- 4.3.0b0
- 4.3.0b1
- 4.3.0b2
- 4.3.0b3
- 4.3.0rc0
- 4.3.0rc1
- 4.3.1
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.7
- 4.3.8
- 4.4.0
- 4.4.0a0
- 4.4.0a1
- 4.4.0a2
- 4.4.0a3
- 4.4.0b0
- 4.4.0b1
- 4.4.0b2
- 4.4.0rc0
- 4.4.0rc1
- 4.4.1
- 4.4.10
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.4.9
- 4.5.0
- 4.5.0a0
- 4.5.0a1
- 4.5.0a2
- 4.5.0a3
- 4.5.0a4
- 4.5.0b0
- 4.5.0b1
- 4.5.0rc0
- 4.5.0rc1
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.0.0, < 4.5.7
Auf 4.5.7 aktualisieren
jupyterlab Ubuntu:25.10
- Softwareversionen
- 4.0.11+ds1+~cs11.25.27-5
- 4.0.11+ds1+~cs11.25.27-6
- 4.0.11+ds1+~cs11.25.27-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterlab Ubuntu:26.10
- Softwareversionen
- 4.0.11+ds1+~cs11.25.27-9
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterlab Ubuntu:26.04:LTS
- Softwareversionen
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-37w4-hwhx-4rc4
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.7
- https://jupyterhub.readthedocs.io/en/5.2.1/explanation/websecurity.html
- https://jupyterlab.readthedocs.io/en/latest/user/extensions.html#extension-manager-implementations
- https://access.redhat.com/security/cve/CVE-2026-42266
- https://bugzilla.redhat.com/show_bug.cgi?id=2477072
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42266.json
- https://access.redhat.com/errata/RHSA-2026:43038
- https://access.redhat.com/errata/RHSA-2026:60520
- https://nvd.nist.gov/vuln/detail/CVE-2026-42266