CVE-2026-42561
CVE-2026-42561 · Python-Multipart: Denial of Service via unbounded multipart part headers
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Python-Multipart is a streaming multipart parser for Python. Prior to 0.0.27, python-multipart has a denial of service vulnerability in multipart part header parsing. When parsing multipart/form-data, MultipartParser previously had no limit on the number of part headers or the size of an individual part header. An attacker could send a request with either many repeated headers without terminating the header block or a single very large header value, causing excessive CPU work before request rejection or completion. This vulnerability is fixed in 0.0.27.
CVSS 7.5 · Hoch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
python-multipart
- Softwareversionen
- < 0.0.27: Betroffen
Keine Korrektur veröffentlicht
python-multipart Debian:12
- Softwareversionen
- 0.0.17-1
- 0.0.17-2
- 0.0.17-3
- 0.0.17-4
- 0.0.17-5
- 0.0.20-1
- 0.0.20-1.1
- 0.0.20-1.1~deb13u1
- 0.0.22-1
- 0.0.26-1
- 0.0.32-1
- 0.0.5-3
- 0.0.6-1
- 0.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-multipart Debian:13
- Softwareversionen
- 0.0.20-1
- 0.0.20-1.1
- 0.0.20-1.1~deb13u1
- 0.0.22-1
- 0.0.26-1
- 0.0.32-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-multipart Debian:14
- Softwareversionen
- 0.0.20-1
- 0.0.20-1.1
- 0.0.20-1.1~deb13u1
- 0.0.22-1
- 0.0.26-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.0.32-1
Auf 0.0.32-1 aktualisieren
python-multipart PyPI
- Softwareversionen
- 0.0.1
- 0.0.10
- 0.0.11
- 0.0.12
- 0.0.13
- 0.0.14
- 0.0.15
- 0.0.16
- 0.0.17
- 0.0.18
- 0.0.19
- 0.0.2
- 0.0.20
- 0.0.21
- 0.0.22
- 0.0.23
- 0.0.24
- 0.0.25
- 0.0.26
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- 0.0.7
- 0.0.8
- 0.0.9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.0.27
Auf 0.0.27 aktualisieren
python-multipart Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 0.0.5-2
- 0.0.5-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-multipart Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 0.0.5-3
- 0.0.6-1
- 0.0.9-1
- 0.0.9-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-multipart Ubuntu:25.10
- Softwareversionen
- 0.0.20-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-multipart Ubuntu:26.10
- Softwareversionen
- 0.0.20-1.1
- 0.0.26-1
- 0.0.32-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-multipart Ubuntu:26.04:LTS
- Softwareversionen
- 0.0.20-1
- 0.0.20-1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/Kludex/python-multipart/security/advisories/GHSA-pp6c-gr5w-3c5g
- https://access.redhat.com/security/cve/CVE-2026-42561
- https://bugzilla.redhat.com/show_bug.cgi?id=2477309
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42561.json
- https://access.redhat.com/errata/RHSA-2026:42132
- https://access.redhat.com/errata/RHSA-2026:42142
- https://access.redhat.com/errata/RHSA-2026:43038
- https://access.redhat.com/errata/RHSA-2026:37275
- https://access.redhat.com/errata/RHSA-2026:44696
- https://access.redhat.com/errata/RHSA-2026:51357
- https://access.redhat.com/errata/RHSA-2026:51194
- https://access.redhat.com/errata/RHSA-2026:51219
- https://nvd.nist.gov/vuln/detail/CVE-2026-42561