p PatchFirst

CVE-2026-44028

CVE-2026-44028

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

An issue was discovered in Nix before 2.34.7 and Lix before 2.95.2. Unbounded recursion in the NAR (Nix Archive) parser could lead to a stack-to-heap overflow when the parser is run on a coroutine stack. The stack is allocated without a guard page, which means that a stack overflow could overwrite memory on the heap and could allow arbitrary code execution as the Nix daemon (run as root in multi-user installations) if ASLR hardening is bypassed. This can be exploited by all users able to connect to the daemon (e.g., in Nix, this is configurable via the allowed-users setting, defaulting to all users). The fixed versions are 2.34.7, 2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7 for Nix (introduced in 2.24.4); and 2.95.2, 2.94.2, and 2.93.4 for Lix (introduced in 2.93.0).

CVSS 7.5 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • nix

    Softwareversionen
    • ≥ 2.24.4, < 2.28.7: Betroffen (semver)
    • ≥ 2.29.0, < 2.29.4: Betroffen (semver)
    • ≥ 2.30.0, < 2.30.5: Betroffen (semver)
    • ≥ 2.31.0, < 2.31.5: Betroffen (semver)
    • ≥ 2.32.0, < 2.32.8: Betroffen (semver)
    • ≥ 2.33.0, < 2.33.6: Betroffen (semver)
    • ≥ 2.34.0, < 2.34.7: Betroffen (semver)

    Auf 2.28.7 aktualisieren; Auf 2.29.4 aktualisieren; Auf 2.30.5 aktualisieren; Auf 2.31.5 aktualisieren; Auf 2.32.8 aktualisieren; Auf 2.33.6 aktualisieren; Auf 2.34.7 aktualisieren

  • lix

    Softwareversionen
    • ≥ 2.93.0, < 2.93.4: Betroffen (semver)
    • ≥ 2.94.0, < 2.94.2: Betroffen (semver)
    • ≥ 2.95.0, < 2.95.2: Betroffen (semver)

    Auf 2.93.4 aktualisieren; Auf 2.94.2 aktualisieren; Auf 2.95.2 aktualisieren

  • nix Debian:13

    Softwareversionen
    • 2.26.3+dfsg-1
    • 2.32.5+dfsg-1
    • 2.32.5+dfsg-2
    • 2.34.3+dfsg-1
    • 2.34.6+dfsg-1
    • 2.34.8+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • nix Debian:14

    Softwareversionen
    • 2.26.3+dfsg-1
    • 2.32.5+dfsg-1
    • 2.32.5+dfsg-2
    • 2.34.3+dfsg-1
    • 2.34.6+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.34.8+dfsg-1

    Auf 2.34.8+dfsg-1 aktualisieren

  • nix Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 2.3.10+dfsg1-1
    • 2.3.10+dfsg1-1build1
    • 2.6.0+dfsg-2
    • 2.6.0+dfsg-3
    • 2.6.0+dfsg-3ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • nix Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 2.16.1+dfsg-3ubuntu1
    • 2.18.1+dfsg-1ubuntu1
    • 2.18.1+dfsg-1ubuntu2
    • 2.18.1+dfsg-1ubuntu4
    • 2.18.1+dfsg-1ubuntu5
    • 2.18.1+dfsg-1ubuntu5+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • nix Ubuntu:25.10

    Softwareversionen
    • 2.24.9+dfsg-2ubuntu2
    • 2.26.3+dfsg-1ubuntu1
    • 2.26.3+dfsg-1ubuntu2
    • 2.26.3+dfsg-1ubuntu4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • nix Ubuntu:26.10

    Softwareversionen
    • 2.34.3+dfsg-1
    • 2.34.6+dfsg-1
    • 2.34.6+dfsg-1build1
    • 2.34.8+dfsg-1
    • 2.34.8+dfsg-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • nix Ubuntu:26.04:LTS

    Softwareversionen
    • 2.26.3+dfsg-1ubuntu4
    • 2.26.3+dfsg-1ubuntu5
    • 2.32.5+dfsg-1ubuntu3
    • 2.32.5+dfsg-2ubuntu1
    • 2.34.3+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →