p PatchFirst

CVE-2026-44486

CVE-2026-44486 · Axios: Proxy-Authorization header leaks to redirect target when proxy is re-evaluated to direct connection

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

Axios is a promise based HTTP client for the browser and Node.js. Prior to 0.32.0 and 1.16.0, Axios’ Node.js HTTP adapter can leak proxy credentials to a redirect target in affected versions. When a request is sent through an authenticated proxy, Axios may add a Proxy-Authorization header. If Axios then follows a redirect and the redirected request is no longer sent through that proxy, the stale Proxy-Authorization header can remain on the redirected request and be sent to the redirect target. This affects Node.js's use of Axios with automatic redirects enabled and an authenticated proxy configuration. Browser adapters are not affected. This vulnerability is fixed in 0.32.0 and 1.16.0.

CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • axios

    Softwareversionen
    • >= 1.0.0, < 1.16.0: Betroffen
    • < 0.32.0: Betroffen

    Keine Korrektur veröffentlicht

  • node-axios Debian:12

    Softwareversionen
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.15.2-1
    • 1.16.0-1
    • 1.18.0-1
    • 1.19.0-1
    • 1.2.1+dfsg-1
    • 1.2.1+dfsg-1+deb12u1
    • 1.20.0-1
    • 1.5.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.8+dfsg-1
    • 1.6.8+dfsg-2
    • 1.7.3+dfsg-1
    • 1.7.4+dfsg-1
    • 1.7.7+dfsg-1
    • 1.7.9+dfsg-1
    • 1.8.4+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Debian:13

    Softwareversionen
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.15.2-1
    • 1.16.0-1
    • 1.18.0-1
    • 1.19.0-1
    • 1.20.0-1
    • 1.8.4+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Debian:14

    Softwareversionen
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.15.2-1
    • 1.8.4+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.16.0-1

    Auf 1.16.0-1 aktualisieren

  • axios npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.0.0, < 1.16.0

    Auf 1.16.0 aktualisieren

  • axios npm

    Betroffene Versionsbereiche
    • SEMVER: < 0.32.0

    Auf 0.32.0 aktualisieren

  • node-axios Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 0.19.0+dfsg-2
    • 0.19.0+dfsg-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 0.21.1+dfsg-1
    • 0.23.0+dfsg-2
    • 0.24.0+dfsg-1
    • 0.25.0+dfsg-2
    • 0.26.0+dfsg-1
    • 0.26.0+dfsg-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 1.2.1+dfsg-1
    • 1.5.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.8+dfsg-2
    • 1.6.8+dfsg-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:25.10

    Softwareversionen
    • 1.7.9+dfsg-1
    • 1.8.4+dfsg-1
    • 1.11.0+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:26.10

    Softwareversionen
    • 1.13.2+dfsg-1build1
    • 1.16.0-1
    • 1.18.0-1
    • 1.19.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-axios Ubuntu:Pro:26.04:LTS

    Softwareversionen
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.2+dfsg-1build1
    • 1.13.2+dfsg-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →