CVE-2026-44891
CVE-2026-44891 · Netty: Denial of Service via Unbounded Headers in StompSubframeDecoder
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Netty is a network application framework for development of protocol servers and clients. Prior to 4.1.136.Final and 4.2.16.Final, io.netty.handler.codec.stomp.StompSubframeDecoder fails to limit the total number of headers or their cumulative size per frame, and the maxLineLength parameter only restricts individual header lines. An attacker can send a large number of short headers that are accumulated in memory inside DefaultStompHeadersSubframe until the JVM throws an OutOfMemoryError, causing denial of service for servers exposing a STOMP endpoint based on StompSubframeDecoder. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
CVSS 7.5 · Hoch · EPSS 0,7%
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
netty
- Softwareversionen
- < 4.1.136.Final: Betroffen
- >= 4.2.0.Final, < 4.2.16.Final: Betroffen
Keine Korrektur veröffentlicht
netty Debian:12
- Softwareversionen
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- 1:4.1.48-7+deb12u2
- 1:4.1.48-8
- 1:4.1.48-9
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Debian:13
- Softwareversionen
- 1:4.1.48-10
- 1:4.1.48-10+deb13u1
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Debian:14
- Softwareversionen
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- 1:4.0.34-1ubuntu0.1~esm2
- 1:4.0.34-1ubuntu0.1~esm3
- 1:4.0.34-1ubuntu0.1~esm4
- 1:4.0.34-1ubuntu0.1~esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- 1:4.1.7-4ubuntu0.1+esm3
- 1:4.1.7-4ubuntu0.1+esm4
- 1:4.1.7-4ubuntu0.1+esm5
- 1:4.1.7-4ubuntu0.1+esm6
- 1:4.1.7-4ubuntu0.1+esm7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- 1:4.1.45-1ubuntu0.1~esm2
- 1:4.1.45-1ubuntu0.1~esm3
- 1:4.1.45-1ubuntu0.1~esm4
- 1:4.1.45-1ubuntu0.1~esm6
- 1:4.1.45-1ubuntu0.1~esm7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm2
- 1:4.1.48-4+deb11u2ubuntu0.1
- 1:4.1.48-4+deb11u2ubuntu0.1+esm1
- 1:4.1.48-4+deb11u2ubuntu0.1+esm3
- 1:4.1.48-4+deb11u2ubuntu0.2
- 1:4.1.48-4+deb11u2ubuntu0.2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- 1:4.1.48-9ubuntu0.1~esm1
- 1:4.1.48-9ubuntu0.1~esm2
- 1:4.1.48-9ubuntu0.1
- 1:4.1.48-9ubuntu0.1+esm1
- 1:4.1.48-9ubuntu0.1+esm3
- 1:4.1.48-9ubuntu0.2
- 1:4.1.48-9ubuntu0.2+esm1
- 1:4.1.48-9ubuntu0.2+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:26.10
- Softwareversionen
- 1:4.1.48-16
- 1:4.1.48-16ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:26.04:LTS
- Softwareversionen
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-16
- 1:4.1.48-16ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/netty/netty/security/advisories/GHSA-vhch-2wf3-m8rp
- https://github.com/netty/netty/pull/17063
- https://github.com/netty/netty/pull/17065
- https://github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- https://github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Final
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Final
- https://nvd.nist.gov/vuln/detail/CVE-2026-44891