p PatchFirst

CVE-2026-45758

CVE-2026-45758 · Malicious code in guardrails-ai 0.10.1 (supply chain compromise)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Guardrails AI is a Python framework that helps build AI applications. On May 11, 2026 at approximately 6:00 PM Pacific, an attacker published a malicious version of `guardrails-ai` (0.10.1) to PyPI. Aany user who installed `guardrails-ai==0.10.1` from PyPI on May 11, 2026 may be affected. Security researchers identified the malicious package within approximately 2 hours of publication, and PyPI quarantined the repository. Based on our telemetry, Guardrails AI maintainers have observed no requests to Guardrails AI infrastructure originating from the malicious 0.10.1 version, and a review of system and access logs has produced no evidence of user data exfiltration through their systems. Users should upgrade to version 0.10.2 or downgrade to version 0.10.0, both of which are unaffected. Those who installed version 0.10.1 should rotate any credentials accessible from their machine (GitHub PATs, cloud provider keys, package registry tokens, API keys) and audit their GitHub account for unauthorized workflows or repositories.

CVSS 9.6 · Kritisch · EPSS 0,3%

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • guardrails

    Softwareversionen
    • = 0.10.1: Betroffen

    Keine Korrektur veröffentlicht

  • guardrails-ai PyPI

    Softwareversionen
    • 0.10.1

    Keine Korrektur veröffentlicht

  • guardrails-ai PyPI

    Softwareversionen
    • 0.1.0
    • 0.1.0rc1
    • 0.1.0rc2
    • 0.1.0rc3
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.1.8
    • 0.1.9
    • 0.10.0
    • 0.10.0a0
    • 0.10.0a1
    • 0.10.0a2
    • 0.10.0a3
    • 0.10.0a4
    • 0.10.0a5
    • 0.2.0
    • 0.2.0a1
    • 0.2.0a2
    • 0.2.0a3
    • 0.2.0a4
    • 0.2.0a5
    • 0.2.0a6
    • 0.2.1
    • 0.2.1a0
    • 0.2.2
    • 0.2.3
    • 0.2.3a1
    • 0.2.4
    • 0.2.4a1
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 0.2.8
    • 0.2.9
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.4
    • 0.4.5
    • 0.5.0
    • 0.5.0a0
    • 0.5.0a1
    • 0.5.0a10
    • 0.5.0a11
    • 0.5.0a12
    • 0.5.0a13
    • 0.5.0a2
    • 0.5.0a3
    • 0.5.0a4
    • 0.5.0a5
    • 0.5.0a6
    • 0.5.0a7
    • 0.5.0a8
    • 0.5.0a9
    • 0.5.1
    • 0.5.10
    • 0.5.11
    • 0.5.12
    • 0.5.13
    • 0.5.14
    • 0.5.15
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    • 0.5.6
    • 0.5.7
    • 0.5.8
    • 0.5.9
    • 0.6.0
    • 0.6.0a1
    • 0.6.0a2
    • 0.6.0a3
    • 0.6.0a4
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.6.4
    • 0.6.5
    • 0.6.6
    • 0.6.7
    • 0.6.8
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.9.0
    • 0.9.0rc0
    • 0.9.1
    • 0.9.2
    • 0.9.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≤ 0.10.1

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →