p PatchFirst

CVE-2026-45809

CVE-2026-45809 · OpenSIPS: Denial of Service in watcherinfo XML generation from oversized watcher URI

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the watcherinfo generation functionality. An attacker can create an oversized watcher entry by sending a SUBSCRIBE Event: presence request with a long From URI, and then trigger presence.winfo watcherinfo XML generation for the same presentity. OpenSIPS copies the stored watcher URI into a fixed-size stack buffer, overflowing it and crashing the process. A remote attacker can crash an OpenSIPS worker in deployments that expose handle_subscribe() and allow watcherinfo (presence.winfo) generation. The issue is configuration-dependent because the presence and presence_xml modules must be loaded and SUBSCRIBE routing must be reachable. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

CVSS 8.7 · Hoch · EPSS 0,6%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • opensips

    Softwareversionen
    • >= 3.4.0, < 3.6.6: Betroffen
    • >= 4.0.0-beta, < 4.0.0-rc1: Betroffen

    Keine Korrektur veröffentlicht

  • opensips Ubuntu:18.04:LTS

    Softwareversionen
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →