CVE-2026-46338
CVE-2026-46338 · PyMdown Extensions: Regression in pymdownx.snippets reintroduces sibling-prefix path traversal bypass despite restrict_base_path
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
PyMdown Extensions is a set of extensions for the Python-Markdown markdown project. From 10.0.1 until 10.21.3, pymdownx.snippets uses a string-prefix containment check in SnippetPreprocessor.get_snippet_path() in pymdownx/snippets.py when `restrict_base_path: True`, allowing markdown snippet directives to read files from sibling paths that share the same base_path prefix, such as docs and docs_internal. This is a regression of CVE-2023-32309. This issue is fixed in version 10.21.3.
CVSS 4.3 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pymdown-extensions
- Softwareversionen
- >= 10.0.1, < 10.21.3: Betroffen
Keine Korrektur veröffentlicht
pymdown-extensions Debian:12
- Softwareversionen
- 10.11.2-1
- 10.13-1
- 10.13-2
- 10.13-3
- 10.13-4
- 10.19.1-1
- 10.19.1-3
- 10.8.1-1
- 10.9-1
- 11.0.1-1
- 9.5-2
- 9.5-3
- 9.5-4
- 9.5-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pymdown-extensions Debian:13
- Softwareversionen
- 10.13-1
- 10.13-1+deb13u1
- 10.13-2
- 10.13-3
- 10.13-4
- 10.19.1-1
- 10.19.1-3
- 11.0.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pymdown-extensions Debian:14
- Softwareversionen
- 10.13-1
- 10.13-2
- 10.13-3
- 10.13-4
- 10.19.1-1
- 10.19.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 11.0.1-1
Auf 11.0.1-1 aktualisieren
pymdown-extensions PyPI
- Softwareversionen
- 10.0.1
- 10.1
- 10.10
- 10.10.1
- 10.10.2
- 10.11
- 10.11.1
- 10.11.2
- 10.12
- 10.13
- 10.14
- 10.14.1
- 10.14.2
- 10.14.3
- 10.15
- 10.16
- 10.16.1
- 10.17
- 10.17.1
- 10.17.2
- 10.18
- 10.19
- 10.19.1
- 10.2
- 10.2.1
- 10.20
- 10.20.1
- 10.21
- 10.21.2
- 10.3
- 10.3.1
- 10.4
- 10.5
- 10.6
- 10.7
- 10.7.1
- 10.8
- 10.8.1
- 10.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 10.0.1, < 10.21.3
Auf 10.21.3 aktualisieren
pymdown-extensions Ubuntu:24.04:LTS
- Softwareversionen
- 9.5-2
- 9.5-4
- 9.5-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pymdown-extensions Ubuntu:26.10
- Softwareversionen
- 10.19.1-3
- 11.0.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pymdown-extensions Ubuntu:26.04:LTS
- Softwareversionen
- 10.13-3
- 10.13-4
- 10.19.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/facelessuser/pymdown-extensions/security/advisories/GHSA-62q4-447f-wv8h
- https://github.com/facelessuser/pymdown-extensions/commit/63b7835776d703d6c339cf2110d9888f676efc0c
- https://github.com/facelessuser/pymdown-extensions/releases/tag/10.21.3
- https://nvd.nist.gov/vuln/detail/CVE-2026-46338