CVE-2026-47241
CVE-2026-47241 · Net::IMAP: Denial of Service via incomplete raw argument validation
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to 0.6.5 and 0.5.15, several Net::IMAP commands accept a raw string argument which is only validated to prevent CRLF injection and then sent verbatim. If this string is derived from user-controlled input, an attacker can force the next command to be absorbed as a continuation of the first command. This will cause the first command to eventually fail, but also prevents it from returning until another command is sent (from another thread). That other command will not return until the connection is closed. This vulnerability is fixed in 0.6.5 and 0.5.15.
CVSS 2.1 · Niedrig · EPSS 0,4%
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
net-imap
- Softwareversionen
- >= 0.6.0, < 0.6.4.1: Betroffen
- < 0.5.15: Betroffen
Keine Korrektur veröffentlicht
ruby3.1 Debian:12
- Softwareversionen
- 3.1.2-7
- 3.1.2-7+deb12u1
- 3.1.2-7+hurd.1
- 3.1.2-8
- 3.1.2-8.1~exp1
- 3.1.2-8.3
- 3.1.2-8.4
- 3.1.2-8.5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.3 Debian:13
- Softwareversionen
- 3.3.8-2
- 3.3.8-2.1
- 3.3.8-2.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.3 Debian:14
- Softwareversionen
- 3.3.8-2
- 3.3.8-2.1
- 3.3.8-2.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- 1.5.6-9+deb8u2build0.14.04.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby2.3 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- 2.3.1-2~16.04.7
- 2.3.1-2~16.04.9
- 2.3.1-2~16.04.10
- 2.3.1-2~16.04.11
- 2.3.1-2~16.04.12
- 2.3.1-2~ubuntu16.04.13
- 2.3.1-2~ubuntu16.04.14
- 2.3.1-2~ubuntu16.04.15
- 2.3.1-2~ubuntu16.04.16
- 2.3.1-2~ubuntu16.04.16+esm1
- 2.3.1-2~ubuntu16.04.16+esm2
- 2.3.1-2~ubuntu16.04.16+esm3
- 2.3.1-2~ubuntu16.04.16+esm4
- 2.3.1-2~ubuntu16.04.16+esm5
- 2.3.1-2~ubuntu16.04.16+esm6
- 2.3.1-2~ubuntu16.04.16+esm7
- 2.3.1-2~ubuntu16.04.16+esm8
- 2.3.1-2~ubuntu16.04.16+esm9
- 2.3.1-2~ubuntu16.04.16+esm10
- 2.3.1-2~ubuntu16.04.16+esm11
- 2.3.1-2~ubuntu16.04.16+esm12
- 2.3.1-2~ubuntu16.04.16+esm14
- 2.3.1-2~ubuntu16.04.16+esm15
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:16.04:LTS
- Softwareversionen
- 1.7.21-2ubuntu4
- 1.7.22-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby2.5 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.5.0~preview1-1ubuntu2
- 2.5.0-4ubuntu1
- 2.5.0-4ubuntu4
- 2.5.0-5ubuntu1
- 2.5.0-6ubuntu1
- 2.5.1-1ubuntu1
- 2.5.1-1ubuntu1.1
- 2.5.1-1ubuntu1.2
- 2.5.1-1ubuntu1.4
- 2.5.1-1ubuntu1.5
- 2.5.1-1ubuntu1.6
- 2.5.1-1ubuntu1.7
- 2.5.1-1ubuntu1.8
- 2.5.1-1ubuntu1.9
- 2.5.1-1ubuntu1.10
- 2.5.1-1ubuntu1.11
- 2.5.1-1ubuntu1.12
- 2.5.1-1ubuntu1.13
- 2.5.1-1ubuntu1.14
- 2.5.1-1ubuntu1.15
- 2.5.1-1ubuntu1.16
- 2.5.1-1ubuntu1.16+esm1
- 2.5.1-1ubuntu1.16+esm3
- 2.5.1-1ubuntu1.16+esm4
- 2.5.1-1ubuntu1.16+esm5
- 2.5.1-1ubuntu1.16+esm6
- 2.5.1-1ubuntu1.16+esm7
- 2.5.1-1ubuntu1.16+esm8
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:18.04:LTS
- Softwareversionen
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby2.7 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 2.7.0-1
- 2.7.0-2
- 2.7.0-3
- 2.7.0-4
- 2.7.0-4ubuntu1
- 2.7.0-5ubuntu1
- 2.7.0-5ubuntu1.1
- 2.7.0-5ubuntu1.2
- 2.7.0-5ubuntu1.3
- 2.7.0-5ubuntu1.4
- 2.7.0-5ubuntu1.5
- 2.7.0-5ubuntu1.6
- 2.7.0-5ubuntu1.7
- 2.7.0-5ubuntu1.8
- 2.7.0-5ubuntu1.9
- 2.7.0-5ubuntu1.10
- 2.7.0-5ubuntu1.11
- 2.7.0-5ubuntu1.12
- 2.7.0-5ubuntu1.13
- 2.7.0-5ubuntu1.14
- 2.7.0-5ubuntu1.15
- 2.7.0-5ubuntu1.16
- 2.7.0-5ubuntu1.17
- 2.7.0-5ubuntu1.18
- 2.7.0-5ubuntu1.18+esm1
- 2.7.0-5ubuntu1.18+esm3
- 2.7.0-5ubuntu1.18+esm4
- 2.7.0-5ubuntu1.18+esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:20.04:LTS
- Softwareversionen
- 9.1.17.0-3
- 9.1.17.0-3build5
- 9.1.17.0-3build6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.0 Ubuntu:22.04:LTS
- Softwareversionen
- 3.0.2-5ubuntu1
- 3.0.2-7
- 3.0.2-7ubuntu2
- 3.0.2-7ubuntu2.1
- 3.0.2-7ubuntu2.2
- 3.0.2-7ubuntu2.3
- 3.0.2-7ubuntu2.4
- 3.0.2-7ubuntu2.5
- 3.0.2-7ubuntu2.6
- 3.0.2-7ubuntu2.7
- 3.0.2-7ubuntu2.8
- 3.0.2-7ubuntu2.10
- 3.0.2-7ubuntu2.11
- 3.0.2-7ubuntu2.12
- 3.0.2-7ubuntu2.13
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:24.04:LTS
- Softwareversionen
- 9.3.9.0+ds-1
- 9.4.5.0+ds-1
- 9.4.5.0+ds-1ubuntu1
- 9.4.6.0+ds-1ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.2 Ubuntu:24.04:LTS
- Softwareversionen
- 3.2.3-1
- 3.2.3-1build2
- 3.2.3-1build3
- 3.2.3-1ubuntu0.24.04.1
- 3.2.3-1ubuntu0.24.04.3
- 3.2.3-1ubuntu0.24.04.5
- 3.2.3-1ubuntu0.24.04.6
- 3.2.3-1ubuntu0.24.04.7
- 3.2.3-1ubuntu0.24.04.8
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:25.10
- Softwareversionen
- 9.4.8.0+ds-2ubuntu1
- 9.4.8.0+ds-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.3 Ubuntu:25.10
- Softwareversionen
- 3.3.7-1ubuntu2
- 3.3.8-2ubuntu1
- 3.3.8-2ubuntu2
- 3.3.8-2ubuntu2.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:26.10
- Softwareversionen
- 9.4.8.0+ds-3ubuntu1
- 9.4.14.0+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.3 Ubuntu:26.10
- Softwareversionen
- 3.3.8-2ubuntu3
- 3.3.8-2.2ubuntu4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:26.04:LTS
- Softwareversionen
- 9.4.8.0+ds-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.3 Ubuntu:26.04:LTS
- Softwareversionen
- 3.3.8-2ubuntu2
- 3.3.8-2ubuntu3
- 3.3.8-2ubuntu3.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht