p PatchFirst

CVE-2026-48061

CVE-2026-48061 · Litestar: AllowedHostsMiddleware bypasses host validation via client-controlled X-Forwarded-Host header

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Litestar is an Asynchronous Server Gateway Interface (ASGI) framework. In versions prior to 2.22.0, an attacker can bypass the allowed hosts validation by omitting the Host header and supplying an X-Forwarded-Host header set to a whitelisted domain. The AllowedHostsMiddleware trusts the X-Forwarded-Host header as a fallback when the Host header is absent. Since X-Forwarded-Host is a client-controllable header, this enables host header injection attacks such as password reset poisoning, cache poisoning, and server-side request routing manipulation. Any application using AllowedHostsConfig is affected when deployed without a reverse proxy that strips X-Forwarded-Host, or when accepting HTTP/1.0 connections. This issue has been fixed in version 2.22.0.

CVSS 5.9 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • litestar

    Softwareversionen
    • < 2.22.0: Betroffen

    Keine Korrektur veröffentlicht

  • litestar PyPI

    Softwareversionen
    • 1.0.0a0
    • 2.0.0
    • 2.0.0a3
    • 2.0.0a4
    • 2.0.0a5
    • 2.0.0a6
    • 2.0.0a7
    • 2.0.0b1
    • 2.0.0b2
    • 2.0.0b3
    • 2.0.0b4
    • 2.0.0rc1
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.10.0
    • 2.11.0
    • 2.12.0
    • 2.12.1
    • 2.13.0
    • 2.14.0
    • 2.15.0
    • 2.15.1
    • 2.15.2
    • 2.16.0
    • 2.17.0
    • 2.18.0
    • 2.19.0
    • 2.2.0
    • 2.2.1
    • 2.20.0
    • 2.21.0
    • 2.21.1
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.5
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.7.0
    • 2.7.1
    • 2.7.2
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.9.0
    • 2.9.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.22.0

    Auf 2.22.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →