p PatchFirst

CVE-2026-48069

CVE-2026-48069 · @grpc/grps-js: An incoming malformed compressed message can cause a client or server crash

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming compressed message can cause a client or server process that uses @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

CVSS 7.5 · Hoch · EPSS 0,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • grpc-node

    Softwareversionen
    • < 1.9.16: Betroffen
    • >= 1.10.0, < 1.10.12: Betroffen
    • >= 1.11.0, < 1.11.4: Betroffen
    • >= 1.12.0, < 1.12.7: Betroffen
    • >= 1.13.0, < 1.13.5: Betroffen
    • >= 1.14.0, < 1.14.4: Betroffen

    Keine Korrektur veröffentlicht

  • @grpc/grpc-js npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.9.16

    Auf 1.9.16 aktualisieren

  • @grpc/grpc-js npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.10.0, < 1.10.12

    Auf 1.10.12 aktualisieren

  • @grpc/grpc-js npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.11.0, < 1.11.4

    Auf 1.11.4 aktualisieren

  • @grpc/grpc-js npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.12.0, < 1.12.7

    Auf 1.12.7 aktualisieren

  • @grpc/grpc-js npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.13.0, < 1.13.5

    Auf 1.13.5 aktualisieren

  • @grpc/grpc-js npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.14.0, < 1.14.4

    Auf 1.14.4 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →