p PatchFirst

CVE-2026-48779

CVE-2026-48779 · ws: Memory exhaustion DoS from tiny fragments and data chunks

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

ws is an open source WebSocket client and server for Node.js. All versions from 1.1.0 up to (but not including) 5.2.5, from 6.0.0 up to 6.2.4, from 7.0.0 up to 7.5.11, and from 8.0.0 up to 8.21.0 are affected by a memory exhaustion DoS vulnerability. A peer can send a high volume of exceptionally small fragments and data chunks, with modest network traffic, to force the remote peer into allocating and holding structural wrappers that consume far more memory than the default documented message-size limit, leading to process termination due to OOM. This issue has been fixed in versions 5.2.5, 6.2.4, 7.5.11, and 8.21.0.

CVSS 7.5 · Hoch · EPSS 1,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • ws

    Softwareversionen
    • >= 1.1.0, < 5.2.5: Betroffen
    • >= 6.0.0, < 6.2.4: Betroffen
    • >= 7.0.0, < 7.5.11: Betroffen
    • >= 8.0.0, < 8.21.0: Betroffen

    Keine Korrektur veröffentlicht

  • node-ws Debian:12

    Softwareversionen
    • 8.11.0+~cs13.7.3-1
    • 8.11.0+~cs13.7.3-2
    • 8.18.0+~cs13.7.11-1
    • 8.18.0+~cs14.5.15-1
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.0+~cs14.19.1-1
    • 8.21.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Debian:13

    Softwareversionen
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.0+~cs14.19.1-1
    • 8.21.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Debian:14

    Softwareversionen
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.21.0+~cs14.19.1-1

    Auf 8.21.0+~cs14.19.1-1 aktualisieren

  • ws npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.1.0, < 5.2.5

    Auf 5.2.5 aktualisieren

  • ws npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.0.0, < 6.2.4

    Auf 6.2.4 aktualisieren

  • ws npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.0.0, < 7.5.11

    Auf 7.5.11 aktualisieren

  • ws npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.21.0

    Auf 8.21.0 aktualisieren

  • node-ws Ubuntu:16.04:LTS

    Softwareversionen
    • 0.7.2+ds1.349b7460-1
    • 1.0.1+ds1.e6ddaae4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:18.04:LTS

    Softwareversionen
    • 1.1.0+ds1.e6ddaae4-3build1
    • 1.1.0+ds1.e6ddaae4-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:20.04:LTS

    Softwareversionen
    • 1.1.0+ds1.e6ddaae4-5
    • 7.2.1-2
    • 7.2.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:22.04:LTS

    Softwareversionen
    • 7.4.2+~cs18.0.8-2
    • 7.5.5+~cs13.0.13-1
    • 8.5.0+~cs13.3.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:24.04:LTS

    Softwareversionen
    • 8.11.0+~cs13.7.3-1
    • 8.11.0+~cs13.7.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:25.10

    Softwareversionen
    • 8.18.0+~cs14.5.15-1
    • 8.18.1+~cs14.18.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:26.10

    Softwareversionen
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ws Ubuntu:26.04:LTS

    Softwareversionen
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →