CVE-2026-48977
CVE-2026-48977 · OpenSlide: Arbitrary memory write with crafted Ventana BIF file
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
OpenSlide is a C library for reading whole slide image files. From 3.4.1 until 4.0.1, OpenSlide's parse_level0_xml() processing in src/openslide-vendor-ventana.c accepts nonpositive row or column tile counts from a crafted Ventana BIF file. The invalid counts produce attacker-controlled relative memory offsets and allow arbitrary values to be written at those offsets, affecting all supported platforms and configurations and resulting in a crash or potential arbitrary code execution. This issue is fixed in version 4.0.1.
CVSS 7.7 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
openslide
- Softwareversionen
- >= 3.4.1, < 4.0.1: Betroffen
Keine Korrektur veröffentlicht
openslide Debian:12
- Softwareversionen
- 3.4.1+dfsg-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.4.1+dfsg-6+deb12u1
Auf 3.4.1+dfsg-6+deb12u1 aktualisieren
openslide Debian:13
- Softwareversionen
- 3.4.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.4.1+dfsg-7+deb13u1
Auf 3.4.1+dfsg-7+deb13u1 aktualisieren
openslide Debian:14
- Softwareversionen
- 3.4.1+dfsg-7
- 3.4.1+dfsg-8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.4.1+dfsg-9
Auf 3.4.1+dfsg-9 aktualisieren
openslide Ubuntu:16.04:LTS
- Softwareversionen
- 3.4.0-1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openslide Ubuntu:18.04:LTS
- Softwareversionen
- 3.4.1+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openslide Ubuntu:20.04:LTS
- Softwareversionen
- 3.4.1+dfsg-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openslide Ubuntu:22.04:LTS
- Softwareversionen
- 3.4.1+dfsg-5
- 3.4.1+dfsg-5build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openslide Ubuntu:24.04:LTS
- Softwareversionen
- 3.4.1+dfsg-6build1
- 3.4.1+dfsg-7
- 3.4.1+dfsg-7build1
- 3.4.1+dfsg-7build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openslide Ubuntu:25.10
- Softwareversionen
- 3.4.1+dfsg-7build2
- 3.4.1+dfsg-7build3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openslide Ubuntu:26.10
- Softwareversionen
- 3.4.1+dfsg-7build4
- 3.4.1+dfsg-9
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
openslide Ubuntu:26.04:LTS
- Softwareversionen
- 3.4.1+dfsg-7build3
- 3.4.1+dfsg-7build4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/openslide/openslide/security/advisories/GHSA-mxg2-48g7-fmwc
- https://github.com/openslide/openslide/pull/751
- https://github.com/openslide/openslide/commit/2be88bd782d9fff46de8e56a99baca523e7917b3
- https://github.com/openslide/openslide/releases/tag/v4.0.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-48977