p PatchFirst

CVE-2026-49209

CVE-2026-49209 · Symfony UX: Denial of service in symfony/ux-live-component via unbounded batch action requests

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Symfony UX is a JavaScript ecosystem for Symfony. From 2.5.0 until 2.36.0 and 3.1.0, Symfony\UX\LiveComponent\Controller\BatchActionController::__invoke() iterates over the client-supplied actions array and issues a full HttpKernel sub-request for each entry; because the array size is never bounded, an authenticated client can submit a single _batch request containing thousands of actions and exhaust CPU, memory, and database connections on the application server. This issue is fixed in versions 2.36.0 and 3.1.0.

CVSS 5.3 · Mittel · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • ux

    Softwareversionen
    • >= 3.0.0, < 3.1.0: Betroffen
    • >= 2.5.0, < 2.36.0: Betroffen

    Keine Korrektur veröffentlicht

  • symfony/ux-live-component Packagist

    Softwareversionen
    • v2.10.0
    • v2.11.0
    • v2.11.1
    • v2.11.2
    • v2.12.0
    • v2.13.0
    • v2.13.1
    • v2.13.2
    • v2.13.3
    • v2.14.0
    • v2.14.1
    • v2.14.2
    • v2.15.0
    • v2.16.0
    • v2.17.0
    • v2.18.0
    • v2.18.1
    • v2.19.0
    • v2.19.2
    • v2.20.0
    • v2.21.0
    • v2.22.0
    • v2.22.1
    • v2.23.0
    • v2.24.0
    • v2.25.0
    • v2.25.1
    • v2.25.2
    • v2.26.0
    • v2.26.1
    • v2.27.0
    • v2.28.0
    • v2.28.1
    • v2.28.2
    • v2.29.0
    • v2.29.1
    • v2.29.2
    • v2.30.0
    • v2.31.0
    • v2.32.0
    • v2.33.0
    • v2.34.0
    • v2.35.0
    • v2.5.0
    • v2.6.0
    • v2.6.1
    • v2.7.0
    • v2.7.1
    • v2.8.0
    • v2.8.1
    • v2.9.0
    • v2.9.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.5.0, < 2.36.0

    Auf 2.36.0 aktualisieren

  • symfony/ux-live-component Packagist

    Softwareversionen
    • v3.0.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.0.0, < 3.1.0

    Auf 3.1.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →