CVE-2026-49265
CVE-2026-49265 · OAuthLib: Timing Attack Vulnerability in PKCE code_verifier Comparison
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. From 3.0.0 until 4.0.0, OAuthLib's PKCE checks in oauthlib/oauth2/rfc6749/grant_types/authorization_code.py compare attacker-supplied code_verifier values with stored challenges using ordinary string equality in code_challenge_method_plain and code_challenge_method_s256. Because the comparison can return after a length difference or the first mismatching character, repeated token endpoint measurements can reveal common-prefix timing information that could potentially allow recovery of the code_verifier, unauthorized access-token acquisition, and account takeover. Practical exploitation requires an intercepted, single-use authorization code and enough measurements to overcome real-world network noise; the local timing benchmark does not establish practical remote account takeover, so the weakness remains a defense-in-depth concern. This issue is fixed in version 4.0.0.
CVSS 6.8 · Mittel · EPSS 0,2% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
oauthlib
- Softwareversionen
- >= 3.0.0, < 4.0.0: Betroffen
Keine Korrektur veröffentlicht
python-oauthlib Debian:12
- Softwareversionen
- 3.2.2-1
- 3.2.2-2
- 3.2.2-3
- 3.2.2-4
- 3.3.1-1
- 3.3.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-oauthlib Debian:13
- Softwareversionen
- 3.2.2-3
- 3.2.2-4
- 3.3.1-1
- 3.3.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-oauthlib Debian:14
- Softwareversionen
- 3.2.2-3
- 3.2.2-4
- 3.3.1-1
- 3.3.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
oauthlib PyPI
- Softwareversionen
- 3.0.0
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- 3.2.0
- 3.2.1
- 3.2.2
- 3.3.0
- 3.3.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.0.0, < 4.0.0
Auf 4.0.0 aktualisieren
python-oauthlib Ubuntu:16.04:LTS
- Softwareversionen
- 1.0.0-1
- 1.0.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-oauthlib Ubuntu:18.04:LTS
- Softwareversionen
- 2.0.1-1
- 2.0.4-1
- 2.0.6-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-oauthlib Ubuntu:20.04:LTS
- Softwareversionen
- 2.1.0-1
- 3.1.0-1ubuntu1
- 3.1.0-1ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-oauthlib Ubuntu:22.04:LTS
- Softwareversionen
- 3.1.0-2
- 3.1.1-1
- 3.2.0-1
- 3.2.0-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-oauthlib Ubuntu:24.04:LTS
- Softwareversionen
- 3.2.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-oauthlib Ubuntu:26.10
- Softwareversionen
- 3.3.1-1build1
- 3.3.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-oauthlib Ubuntu:26.04:LTS
- Softwareversionen
- 3.2.2-3
- 3.3.1-1
- 3.3.1-1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/oauthlib/oauthlib/security/advisories/GHSA-xpv3-w29h-x7cv
- https://github.com/oauthlib/oauthlib/pull/963
- https://github.com/oauthlib/oauthlib/commit/74664d3fe037a354e180e305135c6bab1747a6b0
- https://github.com/oauthlib/oauthlib/releases/tag/v4.0.0
- https://github.com/pypa/advisory-database/tree/main/vulns/oauthlib/PYSEC-2026-4114.yaml
- https://nvd.nist.gov/vuln/detail/CVE-2026-49265