p PatchFirst

CVE-2026-49356

CVE-2026-49356 · Babel: Arbitrary File Read via sourceMappingURL Comment in @babel/core

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Babel is a compiler for writing next generation JavaScript. Prior to 8.0.0-rc.6 and 7.29.6, @babel/core affected by an arbitrary file read via a sourceMappingURL comment. Using @babel/core to compile maliciously crafted code can allow an attacker to read any source map from the system that is running Babel, if the attacker controls the input source code, can read the output source code, and knows the path of the source map file that they want to read. This vulnerability is fixed in 8.0.0-rc.6 and 7.29.6.

CVSS 3.2 · Niedrig · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • babel

    Softwareversionen
    • >= 8.0.0-alpha.0, < 8.0.0-rc.5: Betroffen
    • < 7.29.6: Betroffen

    Keine Korrektur veröffentlicht

  • node-babel7 Debian:12

    Softwareversionen
    • 7.20.15+ds1+~cs214.269.168-10
    • 7.20.15+ds1+~cs214.269.168-11
    • 7.20.15+ds1+~cs214.269.168-12
    • 7.20.15+ds1+~cs214.269.168-13
    • 7.20.15+ds1+~cs214.269.168-14
    • 7.20.15+ds1+~cs214.269.168-15
    • 7.20.15+ds1+~cs214.269.168-16
    • 7.20.15+ds1+~cs214.269.168-17
    • 7.20.15+ds1+~cs214.269.168-18
    • 7.20.15+ds1+~cs214.269.168-3
    • 7.20.15+ds1+~cs214.269.168-3+deb12u1
    • 7.20.15+ds1+~cs214.269.168-3+deb12u2
    • 7.20.15+ds1+~cs214.269.168-4
    • 7.20.15+ds1+~cs214.269.168-5
    • 7.20.15+ds1+~cs214.269.168-6
    • 7.20.15+ds1+~cs214.269.168-7
    • 7.20.15+ds1+~cs214.269.168-8
    • 7.20.15+ds1+~cs214.269.168-9
    • 8.0.4+ds1+~cs177.303.116-1
    • 8.0.4+ds1+~cs177.303.116-2
    • 8.0.4+ds1+~cs177.303.116-3
    • 8.0.6+ds1+~cs177.303.116-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-babel7 Debian:13

    Softwareversionen
    • 7.20.15+ds1+~cs214.269.168-10
    • 7.20.15+ds1+~cs214.269.168-11
    • 7.20.15+ds1+~cs214.269.168-12
    • 7.20.15+ds1+~cs214.269.168-13
    • 7.20.15+ds1+~cs214.269.168-14
    • 7.20.15+ds1+~cs214.269.168-15
    • 7.20.15+ds1+~cs214.269.168-16
    • 7.20.15+ds1+~cs214.269.168-17
    • 7.20.15+ds1+~cs214.269.168-18
    • 7.20.15+ds1+~cs214.269.168-8
    • 7.20.15+ds1+~cs214.269.168-9
    • 8.0.4+ds1+~cs177.303.116-1
    • 8.0.4+ds1+~cs177.303.116-2
    • 8.0.4+ds1+~cs177.303.116-3
    • 8.0.6+ds1+~cs177.303.116-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-babel7 Debian:14

    Softwareversionen
    • 7.20.15+ds1+~cs214.269.168-10
    • 7.20.15+ds1+~cs214.269.168-11
    • 7.20.15+ds1+~cs214.269.168-12
    • 7.20.15+ds1+~cs214.269.168-13
    • 7.20.15+ds1+~cs214.269.168-14
    • 7.20.15+ds1+~cs214.269.168-15
    • 7.20.15+ds1+~cs214.269.168-16
    • 7.20.15+ds1+~cs214.269.168-17
    • 7.20.15+ds1+~cs214.269.168-18
    • 7.20.15+ds1+~cs214.269.168-8
    • 7.20.15+ds1+~cs214.269.168-9
    • 8.0.4+ds1+~cs177.303.116-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.0.4+ds1+~cs177.303.116-2

    Auf 8.0.4+ds1+~cs177.303.116-2 aktualisieren

  • @babel/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0-alpha.0, < 8.0.0-rc.6

    Auf 8.0.0-rc.6 aktualisieren

  • @babel/core npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.29.6

    Auf 7.29.6 aktualisieren

  • babel Ubuntu:16.04:LTS

    Softwareversionen
    • 1.4.0.dfsg-8.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →