CVE-2026-50168
CVE-2026-50168 · Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, an issue in the @angular/platform-server package allows remote attackers to bypass host allowlist constraints and direct server-side outgoing requests to arbitrary external endpoints. This occurs due to a parser differential between the strict WHATWG URL parser used for allowlist validation and the lenient Domino URL parser used to initialize the server emulated DOM. When a server-side request contains a malformed URL with a double port structure (e.g., http://evil.com:80:80/path), Node's strict URL.canParse(url) logic returns false and skips host check validation entirely. However, the same malformed URL is later accepted and parsed leniently by Domino's internal parser, which resolves the origin to http://evil.com:80. The Angular SSR HTTP request interceptor (relativeUrlsTransformerInterceptorFn) then resolves all relative backend HTTP requests against this adopted origin, executing the SSRF attack. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.
CVSS 8.8 · Hoch · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
angular
- Softwareversionen
- >= 22.0.0-next.0, < 22.0.0-rc.2: Betroffen
- >= 21.0.0-next.0, < 21.2.15: Betroffen
- >= 20.0.0-next.0, < 20.3.22: Betroffen
- >= 19.0.0-next.0, < 19.2.23: Betroffen
- <= 18.2.14: Betroffen
Keine Korrektur veröffentlicht
angular.js Debian:12
- Softwareversionen
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Debian:13
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
@angular/platform-server npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 22.0.0-next.0, < 22.0.0-rc.2
Auf 22.0.0-rc.2 aktualisieren
@angular/platform-server npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 20.0.0-next.0, < 20.3.22
Auf 20.3.22 aktualisieren
@angular/platform-server npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 19.0.0-next.0, < 19.2.23
Auf 19.2.23 aktualisieren
@angular/platform-server npm
- Betroffene Versionsbereiche
- SEMVER: ≤ 18.2.14
Keine Korrektur veröffentlicht
@angular/platform-server npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 21.0.0-next.0, < 21.2.15
Auf 21.2.15 aktualisieren
angular.js Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:22.04:LTS
- Softwareversionen
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:24.04:LTS
- Softwareversionen
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:25.10
- Softwareversionen
- 1.8.3-1
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:26.10
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:26.04:LTS
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht