CVE-2026-50171
CVE-2026-50171 · Angular: Denial of Service (DoS) via OOM in Number Formatting (digitsInfo)
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, a Denial of Service (DoS) vulnerability exists in the @angular/common package of Angular. The formatNumber function, which is also utilized by DecimalPipe, PercentPipe, and CurrencyPipe, does not properly validate the upper bounds of the digitsInfo parameter. Specifically, the minimum and maximum fraction digits parsed from the digitsInfo string (e.g., 1.2-4) are converted to integers and used without limits. When parsing a maliciously crafted digitsInfo string with excessively large fraction digit values (e.g., 1.200000000-200000000), the internal roundNumber function attempts to pad the digits array to match the requested fraction size. This results in an unbounded loop that repeatedly pushes elements into an array. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.
CVSS 8.2 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
angular
- Softwareversionen
- >= 22.0.0-next.0, < 22.0.0-rc.2: Betroffen
- >= 21.0.0-next.0, < 21.2.15: Betroffen
- >= 20.0.0-next.0, < 20.3.22: Betroffen
- >= 19.0.0-next.0, < 19.2.23: Betroffen
- <= 18.2.14: Betroffen
Keine Korrektur veröffentlicht
angular.js Debian:12
- Softwareversionen
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Debian:13
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
@angular/common npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 22.0.0-next.0, < 22.0.0-rc.2
Auf 22.0.0-rc.2 aktualisieren
@angular/common npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 20.0.0-next.0, < 20.3.22
Auf 20.3.22 aktualisieren
@angular/common npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 19.0.0-next.0, < 19.2.23
Auf 19.2.23 aktualisieren
@angular/common npm
- Betroffene Versionsbereiche
- SEMVER: ≤ 18.2.14
Keine Korrektur veröffentlicht
@angular/common npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 21.0.0-next.0, < 21.2.15
Auf 21.2.15 aktualisieren
angular.js Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:22.04:LTS
- Softwareversionen
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:24.04:LTS
- Softwareversionen
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:25.10
- Softwareversionen
- 1.8.3-1
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:26.10
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:26.04:LTS
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht