p PatchFirst

CVE-2026-50557

CVE-2026-50557 · Angular: Template and Attribute Namespace Sanitization Bypass (XSS)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22 and 19.2.22, an issue in the @angular/compiler and @angular/core packages allows bypassing element and attribute sanitization/validation through specific namespace workarounds. Specifically, namespaced script elements (e.g., <svg:script> or <:svg:script>) were not properly identified as script elements by the Angular template preparser, allowing them to pass through template compilation without being stripped. Furthermore, security context schema mappings for element attributes did not consistently handle attributes within namespaced elements (like SVG and MathML), opening up gaps where malicious namespaced attributes could bypass runtime and compile-time sanitizers. Combined, these flaws enable an attacker who can inject or supply a template/tag structure with custom namespaces to bypass Angular's script-stripping logic and attribute sanitizers, leading to client-side Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22 and 19.2.22.

CVSS 5.3 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • angular

    Softwareversionen
    • >= 21.0.0-next.0 < 21.2.15: Betroffen
    • >= 22.0.0-next.0 < 22.0.0-rc.2: Betroffen
    • >= 20.0.0-next.0 < 20.3.22: Betroffen
    • >= 19.0.0-next.0 < 19.2.22: Betroffen
    • <= 18.2.14: Betroffen

    Keine Korrektur veröffentlicht

  • angular.js Debian:12

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Debian:13

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.15

    Auf 21.2.15 aktualisieren

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.0-rc.2

    Auf 22.0.0-rc.2 aktualisieren

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.22

    Auf 20.3.22 aktualisieren

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 19.0.0-next.0, < 19.2.22

    Auf 19.2.22 aktualisieren

  • @angular/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≤ 18.2.14

    Keine Korrektur veröffentlicht

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.15

    Auf 21.2.15 aktualisieren

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.0-rc.2

    Auf 22.0.0-rc.2 aktualisieren

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.22

    Auf 20.3.22 aktualisieren

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 19.0.0-next.0, < 19.2.22

    Auf 19.2.22 aktualisieren

  • @angular/compiler npm

    Betroffene Versionsbereiche
    • SEMVER: ≤ 18.2.14

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:22.04:LTS

    Softwareversionen
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:24.04:LTS

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:25.10

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:26.10

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:26.04:LTS

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →