CVE-2026-5244
CVE-2026-5244 · Cesanta Mongoose TLS 1.3 mongoose.c mg_tls_recv_cert heap-based overflow
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A vulnerability has been found in Cesanta Mongoose up to 7.20. This affects the function mg_tls_recv_cert of the file mongoose.c of the component TLS 1.3 Handler. Such manipulation of the argument pubkey leads to heap-based buffer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.21 mitigates this issue. The name of the patch is 0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1. It is advisable to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
CVSS 6.9 · Mittel · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
mongoose
- Softwareversionen
- 7.0: Betroffen
- 7.1: Betroffen
- 7.2: Betroffen
- 7.3: Betroffen
- 7.4: Betroffen
- 7.5: Betroffen
- 7.6: Betroffen
- 7.7: Betroffen
- 7.8: Betroffen
- 7.9: Betroffen
- 7.10: Betroffen
- 7.11: Betroffen
- 7.12: Betroffen
- 7.13: Betroffen
- 7.14: Betroffen
- 7.15: Betroffen
- 7.16: Betroffen
- 7.17: Betroffen
- 7.18: Betroffen
- 7.19: Betroffen
- 7.20: Betroffen
- 7.21: Nicht betroffen
Auf 7.21 aktualisieren
swupdate Debian:12
- Softwareversionen
- 2022.12+dfsg-4
- 2022.12+dfsg-4+deb12u1
- 2022.12+dfsg-4+deb12u1~bpo11+1
- 2022.12+dfsg-4+deb12u2
- 2023.05+dfsg-1
- 2023.05+dfsg-2
- 2023.05+dfsg-2~bpo12+1
- 2023.05+dfsg-3
- 2023.05+dfsg-4
- 2023.05+dfsg-5
- 2023.05+dfsg-5~bpo12+1
- 2023.12+dfsg-1
- 2023.12+dfsg-1~bpo12+1
- 2023.12.1+dfsg-1
- 2023.12.1+dfsg-1~bpo12+1
- 2023.12.1+dfsg-2
- 2023.12.1+dfsg-2~bpo12+1
- 2024.05+dfsg-1
- 2024.05.2+dfsg-1
- 2024.05.2+dfsg-2
- 2024.05.2+dfsg-2~bpo12+1
- 2024.12+dfsg-1
- 2024.12+dfsg-2
- 2024.12+dfsg-2~bpo12+1
- 2024.12.1+dfsg-1
- 2024.12.1+dfsg-1~bpo12+1
- 2024.12.1+dfsg-2
- 2024.12.1+dfsg-3
- 2024.12.1+dfsg-3~bpo12+1
- 2025.05+dfsg-1
- 2025.05+dfsg-2
- 2025.05+dfsg-2~bpo13+1
- 2025.05+dfsg-3
- 2025.05+dfsg-3~bpo13+1
- 2025.12+dfsg-1
- 2025.12+dfsg-10
- 2025.12+dfsg-10~bpo13+1
- 2025.12+dfsg-10~bpo13+2
- 2025.12+dfsg-2
- 2025.12+dfsg-2~bpo13+1
- 2025.12+dfsg-3
- 2025.12+dfsg-4
- 2025.12+dfsg-5
- 2025.12+dfsg-6
- 2025.12+dfsg-7
- 2025.12+dfsg-7~bpo13+1
- 2025.12+dfsg-8
- 2025.12+dfsg-9
- 2026.05+dfsg-1
- 2026.05+dfsg-2
- 2026.05+dfsg-3
- 2026.05+dfsg-3~bpo13+1
- 2026.05+dfsg-4
- 2026.05.1+dfsg-1
- 2026.05.1+dfsg-1~bpo13+1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
swupdate Debian:13
- Softwareversionen
- 2024.12.1+dfsg-3
- 2024.12.1+dfsg-3+deb13u1
- 2024.12.1+dfsg-3+deb13u2
- 2025.05+dfsg-1
- 2025.05+dfsg-2
- 2025.05+dfsg-2~bpo13+1
- 2025.05+dfsg-3
- 2025.05+dfsg-3~bpo13+1
- 2025.12+dfsg-1
- 2025.12+dfsg-10
- 2025.12+dfsg-10~bpo13+1
- 2025.12+dfsg-10~bpo13+2
- 2025.12+dfsg-2
- 2025.12+dfsg-2~bpo13+1
- 2025.12+dfsg-3
- 2025.12+dfsg-4
- 2025.12+dfsg-5
- 2025.12+dfsg-6
- 2025.12+dfsg-7
- 2025.12+dfsg-7~bpo13+1
- 2025.12+dfsg-8
- 2025.12+dfsg-9
- 2026.05+dfsg-1
- 2026.05+dfsg-2
- 2026.05+dfsg-3
- 2026.05+dfsg-3~bpo13+1
- 2026.05+dfsg-4
- 2026.05.1+dfsg-1
- 2026.05.1+dfsg-1~bpo13+1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
swupdate Debian:14
- Softwareversionen
- 2024.12.1+dfsg-3
- 2025.05+dfsg-1
- 2025.05+dfsg-2
- 2025.05+dfsg-2~bpo13+1
- 2025.05+dfsg-3
- 2025.05+dfsg-3~bpo13+1
- 2025.12+dfsg-1
- 2025.12+dfsg-10~bpo13+1
- 2025.12+dfsg-10~bpo13+2
- 2025.12+dfsg-2
- 2025.12+dfsg-2~bpo13+1
- 2025.12+dfsg-3
- 2025.12+dfsg-4
- 2025.12+dfsg-5
- 2025.12+dfsg-6
- 2025.12+dfsg-7
- 2025.12+dfsg-7~bpo13+1
- 2025.12+dfsg-8
- 2025.12+dfsg-9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2025.12+dfsg-10
Auf 2025.12+dfsg-10 aktualisieren
swupdate Ubuntu:22.04:LTS
- Softwareversionen
- 2020.11-2
- 2021.04-1.1
- 2021.04-2
- 2021.04-2build1
- 2021.11-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
swupdate Ubuntu:24.04:LTS
- Softwareversionen
- 2023.05+dfsg-3
- 2023.05+dfsg-4
- 2023.05+dfsg-4build1
- 2023.05+dfsg-5
- 2023.12+dfsg-1
- 2023.12.1+dfsg-1ubuntu1
- 2023.12.1+dfsg-1ubuntu4
- 2023.12.1+dfsg-1ubuntu5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
swupdate Ubuntu:25.10
- Softwareversionen
- 2024.12.1+dfsg-1build2
- 2024.12.1+dfsg-2
- 2024.12.1+dfsg-3
- 2025.05+dfsg-2ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
swupdate Ubuntu:26.10
- Softwareversionen
- 2025.12+dfsg-4ubuntu1
- 2026.05+dfsg-3ubuntu2
- 2026.05+dfsg-4ubuntu1
- 2026.05.1+dfsg-1ubuntu1
- 2026.05.1+git20261001+dfsg-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
swupdate Ubuntu:26.04:LTS
- Softwareversionen
- 2025.05+dfsg-2ubuntu1
- 2025.05+dfsg-3ubuntu1
- 2025.12+dfsg-1ubuntu1
- 2025.12+dfsg-2ubuntu1
- 2025.12+dfsg-3ubuntu1
- 2025.12+dfsg-4ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://vuldb.com/vuln/354825
- https://vuldb.com/vuln/354825/cti
- https://vuldb.com/submit/770063
- https://github.com/cesanta/mongoose/commit/0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1
- https://github.com/cesanta/mongoose/releases/tag/7.21
- https://github.com/cesanta/mongoose/
- https://nvd.nist.gov/vuln/detail/CVE-2026-5244