p PatchFirst

CVE-2026-52830

CVE-2026-52830 · fast-mcp-telegram: Bearer token path traversal bypasses reserved Telegram session protection

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

fast-mcp-telegram is a Telegram MCP Server. Prior to 0.19.1, fast-mcp-telegram validates HTTP Bearer tokens by joining the raw token string into a session-file path. The verifier rejects the exact reserved token telegram, but it does not reject path separators or normalize the path before checking whether the session file exists. A remote HTTP client can therefore authenticate as the default legacy session with a token such as ../fast-mcp-telegram/telegram when the documented default session file ~/.config/fast-mcp-telegram/telegram.session exists. This bypasses the reserved session name control that is intended to prevent HTTP multi-user sessions from colliding with the default stdio or legacy account. With account-prefixed MCP tools enabled, the attacker still sees and calls the prefixed tools for the default account, so the prefix middleware does not stop the session selection bypass. This vulnerability is fixed in 0.19.1.

CVSS 9.4 · Kritisch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • fast-mcp-telegram

    Softwareversionen
    • < 0.19.1: Betroffen

    Keine Korrektur veröffentlicht

  • fast-mcp-telegram PyPI

    Softwareversionen
    • 0.0.1
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.10.0
    • 0.10.1
    • 0.10.2
    • 0.11.0
    • 0.11.1
    • 0.12.0
    • 0.12.1
    • 0.12.2
    • 0.12.3
    • 0.13.0
    • 0.13.1
    • 0.14.0
    • 0.14.1
    • 0.14.2
    • 0.15.0
    • 0.16.0
    • 0.16.1
    • 0.16.2
    • 0.16.3
    • 0.16.4
    • 0.16.5
    • 0.16.6
    • 0.17.0
    • 0.17.1
    • 0.17.2
    • 0.17.3
    • 0.18.0
    • 0.18.1
    • 0.19.0
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.4
    • 0.4.5
    • 0.5.0
    • 0.6.0
    • 0.6.1
    • 0.7.0
    • 0.7.1
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.9.0
    • 0.9.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.19.1

    Auf 0.19.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →