CVE-2026-52854
CVE-2026-52854 · mediawiki/maps: Stored XSS through the overlays parameter in the display_map parser function
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Maps is a MediaWiki extension that enables visualization of geographic data through dynamic embedded maps. Prior to version 12.1.3, the display_map parser function in the Leaflet service accepts attacker-controlled HTML in the overlays parameter, and resources/leaflet/jquery.leaflet.js uses the overlay name as a Leaflet layer-control label without escaping it. A wiki user with the edit permission can store malicious wikitext that causes script execution when another user previews or views the affected map. The script executes in the viewing user's browser session and can access data or perform actions available to that user. This issue is fixed in version 12.1.3.
CVSS 8.6 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
maps
- Softwareversionen
- < 12.1.3: Betroffen
Keine Korrektur veröffentlicht
mediawiki/maps Packagist
- Softwareversionen
- 10.0.0
- 10.1.0
- 10.1.1
- 10.1.2
- 10.2.0
- 10.3.0
- 11.0.0
- 11.0.1
- 12.0.0
- 12.1.0
- 12.1.1
- 12.1.2
- 3.0
- 3.0-RC2
- 3.0.1
- 3.1
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 3.4.0
- 3.4.1
- 3.5.0
- 3.6.0
- 3.7.0
- 3.8.0
- 3.8.1
- 3.8.2
- 4.0.0
- 4.0.0-RC1
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.1.0
- 4.2.0
- 4.2.1
- 4.3.0
- 4.4.0
- 5.0.0
- 5.0.1
- 5.0.2
- 5.1.0
- 5.2.0
- 5.3.0
- 5.4.0
- 5.5.0
- 5.5.1
- 5.5.2
- 5.5.3
- 5.5.4
- 5.5.5
- 5.6.0
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.0.4
- 6.1.0
- 6.2.0
- 6.2.1
- 6.2.2
- 6.3.0
- 7.0.0
- 7.1.0
- 7.10.0
- 7.11.0
- 7.12.0
- 7.12.1
- 7.12.2
- 7.13.0
- 7.14.0
- 7.15.0
- 7.15.1
- 7.15.2
- 7.15.3
- 7.15.4
- 7.15.5
- 7.15.6
- 7.16.0
- 7.17.0
- 7.17.1
- 7.17.2
- 7.18.0
- 7.19.0
- 7.2.0
- 7.20.0
- 7.20.1
- 7.3.0
- 7.3.1
- 7.3.2
- 7.3.3
- 7.4.0
- 7.4.1
- 7.5.0
- 7.6.0
- 7.7.0
- 7.8.0
- 7.8.1
- 7.8.2
- 7.8.3
- 7.9.0
- 8.0.0
- 9.0.0
- 9.0.1
- 9.0.2
- 9.0.3
- 9.0.4
- 9.0.5
- 9.0.6
- 9.0.7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 12.1.3
Auf 12.1.3 aktualisieren
mediawiki Ubuntu:18.04:LTS
- Softwareversionen
- 1:1.27.3-1
- 1:1.27.4-1
- 1:1.27.4-2
- 1:1.27.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mediawiki Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1:1.31.2-1ubuntu1
- 1:1.31.5-1
- 1:1.31.5-1ubuntu1
- 1:1.31.5-2
- 1:1.31.5-3
- 1:1.31.5-3ubuntu1
- 1:1.31.6-1
- 1:1.31.7-1
- 1:1.31.7-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mediawiki Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1:1.35.3-1
- 1:1.35.4-1
- 1:1.35.5-1
- 1:1.35.5-1ubuntu1
- 1:1.35.5-1ubuntu2
- 1:1.35.5-1ubuntu3
- 1:1.35.6-1
- 1:1.35.6-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mediawiki Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 1:1.39.4-2
- 1:1.39.5-1
- 1:1.39.6-1
- 1:1.39.7-1
- 1:1.39.7-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mediawiki Ubuntu:26.10
- Softwareversionen
- 1:1.43.8+dfsg-2
- 1:1.43.9+dfsg-1
- 1:1.43.9+dfsg-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mediawiki Ubuntu:26.04:LTS
- Softwareversionen
- 1:1.43.3+dfsg-1
- 1:1.43.5+dfsg-1
- 1:1.43.6+dfsg-2
- 1:1.43.8+dfsg-1
- 1:1.43.8+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/ProfessionalWiki/Maps/security/advisories/GHSA-4h7g-5542-v3fc
- https://github.com/ProfessionalWiki/Maps/pull/899
- https://github.com/ProfessionalWiki/Maps/commit/737a993fc2f40499e9bb22198fd1d56c25613806
- https://github.com/ProfessionalWiki/Maps/blob/12.1.3/RELEASE-NOTES.md
- https://github.com/ProfessionalWiki/Maps/releases/tag/12.1.3
- https://nvd.nist.gov/vuln/detail/CVE-2026-52854