CVE-2026-53615
CVE-2026-53615 · util-linux libblkid DOS extended-partition overflow produces invalid partition metadata
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
util-linux is a random collection of Linux utilities. Before util-linux 2.41.4, `parse_dos_extended()` in `libblkid/src/partitions/dos.c` computes an extended-partition start sector with 32-bit addition and does not apply the extended-area bounds checks to the first two EBR entries. A local attacker who causes a crafted DOS extended-partition disk image or removable medium to be probed can wrap `cur_start + start` to sector zero and cause libblkid to report a false partition overlapping the MBR. This directly compromises the integrity of the reported partition metadata; disk modification or availability loss requires a separate downstream consumer to act on that metadata. This issue is fixed in 2.41.4.
CVSS 8.0 · Hoch · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
util-linux
- Softwareversionen
- < 2.41.4: Betroffen
Keine Korrektur veröffentlicht
util-linux Debian:12
- Softwareversionen
- 2.38.1-5
- 2.38.1-5+deb12u1
- 2.38.1-5+deb12u2
- 2.38.1-5+deb12u3
- 2.38.1-5+loong64
- 2.38.1-6
- 2.39.1-1
- 2.39.1-2
- 2.39.1-3
- 2.39.1-4
- 2.39.2-1
- 2.39.2-2
- 2.39.2-2.1
- 2.39.2-2.2
- 2.39.2-3
- 2.39.2-4
- 2.39.2-5
- 2.39.2-6
- 2.39.3-1
- 2.39.3-10
- 2.39.3-11
- 2.39.3-2
- 2.39.3-3
- 2.39.3-4
- 2.39.3-5
- 2.39.3-6
- 2.39.3-6.1
- 2.39.3-6.1~exp1
- 2.39.3-7
- 2.39.3-8
- 2.39.3-9
- 2.40-1
- 2.40-2
- 2.40-3
- 2.40-4
- 2.40-5
- 2.40-6
- 2.40-7
- 2.40-8
- 2.40.1-1
- 2.40.1-2
- 2.40.1-3
- 2.40.1-4
- 2.40.1-4+hurd.1
- 2.40.1-6
- 2.40.1-7
- 2.40.1-8
- 2.40.1-8.1
- 2.40.1-9
- 2.40.2-1
- 2.40.2-10
- 2.40.2-11
- 2.40.2-12
- 2.40.2-12+hurd.1
- 2.40.2-13
- 2.40.2-14
- 2.40.2-2
- 2.40.2-3
- 2.40.2-4
- 2.40.2-5
- 2.40.2-6
- 2.40.2-7
- 2.40.2-8
- 2.40.2-9
- 2.40.3-1
- 2.40.4-1
- 2.40.4-2
- 2.40.4-3
- 2.40.4-4
- 2.40.4-5
- 2.40~rc2-1
- 2.40~rc2-2
- 2.40~rc2-3
- 2.40~rc2-4
- 2.40~rc2-5
- 2.40~rc2-6
- 2.40~rc2-7
- 2.40~rc2-8
- 2.41-1
- 2.41-2
- 2.41-3
- 2.41-4
- 2.41-5
- 2.41.1-1
- 2.41.1-2
- 2.41.1-3
- 2.41.1-4
- 2.41.2-1
- 2.41.2-2
- 2.41.2-3
- 2.41.2-4
- 2.41.3-1
- 2.41.3-2
- 2.41.3-3
- 2.41.3-4
- 2.41~rc1-1
- 2.41~rc1-2
- 2.41~rc2-1
- 2.42-1
- 2.42-2
- 2.42-3
- 2.42-4
- 2.42-5
- 2.42-6
- 2.42.1-1
- 2.42.1-2
- 2.42.1-3
- 2.42.1-4
- 2.42.1-5
- 2.42.1-6
- 2.42.2-1
- 2.42.2-2
- 2.42.2-3
- 2.42.2-4
- 2.42.3-1
- 2.42.4-1
- 2.42~rc1-1
- 2.42~rc1-2
- 2.42~rc1-3
- 2.42~rc2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Debian:13
- Softwareversionen
- 2.41-5
- 2.41.1-1
- 2.41.1-2
- 2.41.1-3
- 2.41.1-4
- 2.41.2-1
- 2.41.2-2
- 2.41.2-3
- 2.41.2-4
- 2.41.3-1
- 2.41.3-2
- 2.41.3-3
- 2.41.3-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.41.5-0+deb13u1
Auf 2.41.5-0+deb13u1 aktualisieren
util-linux Debian:14
- Softwareversionen
- 2.41-5
- 2.41.1-1
- 2.41.1-2
- 2.41.1-3
- 2.41.1-4
- 2.41.2-1
- 2.41.2-2
- 2.41.2-3
- 2.41.2-4
- 2.41.3-1
- 2.41.3-2
- 2.41.3-3
- 2.41.3-4
- 2.42~rc1-1
- 2.42~rc1-2
- 2.42~rc1-3
- 2.42~rc2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42-1
Auf 2.42-1 aktualisieren
util-linux Ubuntu:14.04:LTS
- Softwareversionen
- 2.20.1-5.1ubuntu9
- 2.20.1-5.1ubuntu10
- 2.20.1-5.1ubuntu11
- 2.20.1-5.1ubuntu12
- 2.20.1-5.1ubuntu13
- 2.20.1-5.1ubuntu14
- 2.20.1-5.1ubuntu15
- 2.20.1-5.1ubuntu16
- 2.20.1-5.1ubuntu17
- 2.20.1-5.1ubuntu18
- 2.20.1-5.1ubuntu19
- 2.20.1-5.1ubuntu20
- 2.20.1-5.1ubuntu20.1
- 2.20.1-5.1ubuntu20.2
- 2.20.1-5.1ubuntu20.3
- 2.20.1-5.1ubuntu20.4
- 2.20.1-5.1ubuntu20.6
- 2.20.1-5.1ubuntu20.7
- 2.20.1-5.1ubuntu20.9
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.26.2-6ubuntu3
- 2.27-3ubuntu1
- 2.27.1-1ubuntu2
- 2.27.1-1ubuntu3
- 2.27.1-1ubuntu4
- 2.27.1-3ubuntu1
- 2.27.1-4ubuntu1
- 2.27.1-6ubuntu1
- 2.27.1-6ubuntu2
- 2.27.1-6ubuntu3
- 2.27.1-6ubuntu3.1
- 2.27.1-6ubuntu3.2
- 2.27.1-6ubuntu3.3
- 2.27.1-6ubuntu3.4
- 2.27.1-6ubuntu3.6
- 2.27.1-6ubuntu3.7
- 2.27.1-6ubuntu3.8
- 2.27.1-6ubuntu3.9
- 2.27.1-6ubuntu3.10
- 2.27.1-6ubuntu3.10+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Ubuntu:18.04:LTS
- Softwareversionen
- 2.30.1-0ubuntu4
- 2.30.2-0.1ubuntu1
- 2.30.2-0.1ubuntu2
- 2.30.2-0.1ubuntu3
- 2.31.1-0.4ubuntu2
- 2.31.1-0.4ubuntu3
- 2.31.1-0.4ubuntu3.1
- 2.31.1-0.4ubuntu3.2
- 2.31.1-0.4ubuntu3.3
- 2.31.1-0.4ubuntu3.4
- 2.31.1-0.4ubuntu3.5
- 2.31.1-0.4ubuntu3.6
- 2.31.1-0.4ubuntu3.7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 2.34-0.1ubuntu2
- 2.34-0.1ubuntu4
- 2.34-0.1ubuntu5
- 2.34-0.1ubuntu6
- 2.34-0.1ubuntu7
- 2.34-0.1ubuntu8
- 2.34-0.1ubuntu9
- 2.34-0.1ubuntu9.1
- 2.34-0.1ubuntu9.3
- 2.34-0.1ubuntu9.4
- 2.34-0.1ubuntu9.5
- 2.34-0.1ubuntu9.6
- 2.34-0.1ubuntu9.6+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Ubuntu:22.04:LTS
- Softwareversionen
- 2.36.1-8ubuntu1
- 2.37.2-4ubuntu1
- 2.37.2-4ubuntu2
- 2.37.2-4ubuntu3
- 2.37.2-4ubuntu3.3
- 2.37.2-4ubuntu3.4
- 2.37.2-4ubuntu3.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.37.2-4ubuntu3.6
Auf 2.37.2-4ubuntu3.6 aktualisieren
util-linux Ubuntu:24.04:LTS
- Softwareversionen
- 2.39.1-4ubuntu2
- 2.39.2-6ubuntu1
- 2.39.3-6ubuntu2
- 2.39.3-9ubuntu2
- 2.39.3-9ubuntu4
- 2.39.3-9ubuntu6
- 2.39.3-9ubuntu6.1
- 2.39.3-9ubuntu6.2
- 2.39.3-9ubuntu6.3
- 2.39.3-9ubuntu6.4
- 2.39.3-9ubuntu6.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.39.3-9ubuntu6.6
Auf 2.39.3-9ubuntu6.6 aktualisieren
util-linux Ubuntu:25.10
- Softwareversionen
- 2.40.2-14ubuntu1
- 2.41-4ubuntu2
- 2.41-4ubuntu3
- 2.41-4ubuntu4
- 2.41-4ubuntu4.1
- 2.41-4ubuntu4.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Ubuntu:26.10
- Softwareversionen
- 2.41.3-3ubuntu2
- 2.42.2-1ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
util-linux Ubuntu:26.04:LTS
- Softwareversionen
- 2.41-4ubuntu4
- 2.41.2-4ubuntu1
- 2.41.2-4ubuntu2
- 2.41.2-4ubuntu3
- 2.41.3-3ubuntu1
- 2.41.3-3ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.41.3-3ubuntu2.2
Auf 2.41.3-3ubuntu2.2 aktualisieren
Originalquellen
- https://github.com/util-linux/util-linux/security/advisories/GHSA-h4rw-gv36-wmp5
- https://github.com/util-linux/util-linux/commit/05c2dbadf34cc74192287f377904afaaf4061623
- https://github.com/util-linux/util-linux/commit/a2d858176b609ab5b8535021a3af9cd302d23d31
- https://github.com/util-linux/util-linux/commit/e9d544d013267ea86b70ee8ff78abd280e6641af
- https://github.com/util-linux/util-linux/releases/tag/v2.41.4
- https://nvd.nist.gov/vuln/detail/CVE-2026-53615