p PatchFirst

CVE-2026-53754

CVE-2026-53754 · Crawl4AI: SSRF filter bypass in Docker server via IPv6 transition forms (NAT64 / 6to4 / unspecified / v4-mapped)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Crawl4AI is an open-source LLM friendly web crawler & scraper. Prior to 0.8.8, the Docker API server's SSRF protection (validate_webhook_url / validate_url_destination in deploy/docker/utils.py) used an explicit IPv4/IPv6 CIDR blocklist that missed several address families. An attacker could reach internal services and cloud metadata endpoints (e.g. 169.254.169.254) despite the filter by encoding an internal IPv4 address inside an IPv6 transition form, or by using the IPv6 unspecified address. Because the Docker API is unauthenticated by default (jwt_enabled: false), no credentials are required. This vulnerability is fixed in 0.8.8.

CVSS 7.5 · Hoch · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • crawl4ai

    Softwareversionen
    • < 0.8.8: Betroffen

    Keine Korrektur veröffentlicht

  • crawl4ai PyPI

    Softwareversionen
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    • 0.3.71
    • 0.3.72
    • 0.3.73
    • 0.3.731
    • 0.3.74
    • 0.3.741
    • 0.3.742
    • 0.3.743
    • 0.3.744
    • 0.3.745
    • 0.3.746
    • 0.3.8
    • 0.4.0
    • 0.4.1
    • 0.4.21
    • 0.4.22
    • 0.4.23
    • 0.4.24
    • 0.4.241
    • 0.4.242
    • 0.4.243
    • 0.4.244
    • 0.4.245
    • 0.4.246
    • 0.4.247
    • 0.4.248
    • 0.4.248b3
    • 0.4.3b1
    • 0.4.3b2
    • 0.4.3b3
    • 0.5.0
    • 0.5.0.post1
    • 0.5.0.post2
    • 0.5.0.post3
    • 0.5.0.post4
    • 0.5.0.post5
    • 0.5.0.post6
    • 0.5.0.post7
    • 0.5.0.post8
    • 0.6.0
    • 0.6.0rc1
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    • 0.7.4
    • 0.7.5
    • 0.7.6
    • 0.7.7
    • 0.7.8
    • 0.8.0
    • 0.8.5
    • 0.8.6
    • 0.8.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.8

    Auf 0.8.8 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →