p PatchFirst

CVE-2026-54264

CVE-2026-54264 · Angular: Sensitive Header Leakage on Cross-Origin Redirects in Angular Service Worker

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, an information disclosure vulnerability exists in the @angular/service-worker package of the Angular framework. When the Service Worker fetches assets, it preserves metadata (such as headers) from the original request. However, on cross-origin redirects, the Service Worker fails to strip sensitive headers, violating the Fetch redirect algorithm. This allows a remote attacker to obtain sensitive credentials (e.g., Authorization tokens, Proxy-Authorization credentials, or session cookies) by triggering a cross-origin redirect to an untrusted external origin. This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

CVSS 8.3 · Hoch · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • angular

    Softwareversionen
    • >= 22.0.0-next.0 < 22.0.1: Betroffen
    • >= 21.0.0-next.0 < 21.2.17: Betroffen
    • >= 20.0.0-next.0 < 20.3.25: Betroffen
    • <= 19.2.25: Betroffen

    Keine Korrektur veröffentlicht

  • angular.js Debian:12

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Debian:13

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • @angular/service-worker npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.1

    Auf 22.0.1 aktualisieren

  • @angular/service-worker npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.17

    Auf 21.2.17 aktualisieren

  • @angular/service-worker npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.25

    Auf 20.3.25 aktualisieren

  • @angular/service-worker npm

    Betroffene Versionsbereiche
    • SEMVER: ≤ 19.2.25

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:22.04:LTS

    Softwareversionen
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:24.04:LTS

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:25.10

    Softwareversionen
    • 1.8.3-1
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:26.10

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • angular.js Ubuntu:26.04:LTS

    Softwareversionen
    • 1.8.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →